Bug 1220862 - The installer icon (and everything else in ~/Desktop) is not displayed anywhere on the Plasma Desktop 5 desktop
Summary: The installer icon (and everything else in ~/Desktop) is not displayed anywhe...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kde-settings
Version: 22
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException https://fedor...
: f22-kde-liveinst (view as bug list)
Depends On:
Blocks: F22FinalFreezeException F22Blocker-kde plasma5
TreeView+ depends on / blocked
 
Reported: 2015-05-12 15:59 UTC by Kevin Kofler
Modified: 2015-08-24 07:06 UTC (History)
13 users (show)

Fixed In Version: f22-kde-theme-22.3-1.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-04 20:20:18 UTC


Attachments (Terms of Use)

Description Kevin Kofler 2015-05-12 15:59:29 UTC
Description of problem:
In Plasma 4, we used to change the default setup to add a folder view widget displaying the contents of ~/Desktop. (This used to be the upstream default long ago.) In Plasma 5, we are no longer doing that. As a result, the installer is no longer shown on the desktop. We should either put the folder view widget back, or let the desktop BE the folder view.

Comment 1 Kevin Kofler 2015-05-12 16:07:44 UTC
Proposing as a freeze exception, because this is making the installer less discoverable.

Comment 2 Jaroslav Reznik 2015-05-13 13:06:42 UTC
And it seems like upstream changed the mind and folder view can be set as default desktop.

I have initial code to do something similar to what Workstation does but it's not yet prime time.

+1 FE

Comment 3 Jan Grulich 2015-05-14 12:37:35 UTC
This can be solved simply by editing plasma-org.kde.plasma.desktop-appletrc file, where we just need to change plugin=org.kde.desktopcontainment to plugin=org.kde.folder either for the first occurence (which should be the first desktop) or for all of them.

Comment 4 Kamil Páral 2015-05-14 17:58:52 UTC
Discussed at the 2015-05-14 blocker review meeting.[1] Voted as AcceptedFreezeException - a simple change to display a folder (with the icon) on the live desktop will be accepted, it makes the installer more discoverable

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2015-05-14

Comment 5 Kevin Kofler 2015-05-16 22:20:32 UTC
Why would we want to do this only for the live image? IMHO we should just make org.kde.folder the default everywhere.

Comment 6 Rex Dieter 2015-05-16 23:44:11 UTC
Well, the immediate issue was having an installer shortcut present on desktop on the live image.

I do agree that it may be also worth considering (for consistency) doing this everywhere (not just live image).

Comment 7 Rex Dieter 2015-05-18 14:33:20 UTC
Immediate spin-kickstarts fix adding folderview widget on kde-live:

https://git.fedorahosted.org/cgit/spin-kickstarts.git/commit/?h=f22&id=16a5bf2a4df4c8bb67340a406421c77432762813

Comment 8 Rex Dieter 2015-05-19 15:16:16 UTC
*** Bug 1199460 has been marked as a duplicate of this bug. ***

Comment 9 Jan Grulich 2015-05-20 10:52:05 UTC
Unfortunately the mentioned commit is not enough, because all Plasma updates scripts are not executed during the first initialization. I just pushed a fix to plasma-workspace, so if we want this fixed we need to include this build in the next image. Not mentioning that plasma-workspace will require latest f22-kde-theme package.

Comment 10 Fedora Update System 2015-05-21 14:44:03 UTC
f22-kde-theme-22.3-1.fc22, plasma-desktop-5.3.0-6.fc22, plasma-workspace-5.3.0-8.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/FEDORA-2015-8453/plasma-desktop-5.3.0-6.fc22,plasma-workspace-5.3.0-8.fc22,f22-kde-theme-22.3-1.fc22

Comment 11 Fedora Update System 2015-05-22 02:32:23 UTC
Package f22-kde-theme-22.3-1.fc22, plasma-desktop-5.3.0-6.fc22, plasma-workspace-5.3.0-8.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing f22-kde-theme-22.3-1.fc22 plasma-desktop-5.3.0-6.fc22 plasma-workspace-5.3.0-8.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-8453/plasma-desktop-5.3.0-6.fc22,plasma-workspace-5.3.0-8.fc22,f22-kde-theme-22.3-1.fc22
then log in and leave karma (feedback).

Comment 12 Fedora Update System 2015-06-04 20:20:18 UTC
f22-kde-theme-22.3-1.fc22, plasma-desktop-5.3.0-6.fc22, plasma-workspace-5.3.0-8.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.