Bug 1220866 - RFE: extend autopart with options to disable separate boot/swap partitions
Summary: RFE: extend autopart with options to disable separate boot/swap partitions
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vendula Poncova
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: PPCTracker
TreeView+ depends on / blocked
 
Reported: 2015-05-12 16:14 UTC by Peter Robinson
Modified: 2017-05-01 18:17 UTC (History)
10 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-05-01 18:17:25 UTC


Attachments (Terms of Use)

Description Peter Robinson 2015-05-12 16:14:34 UTC
The Fedora cloud images use the following kickstart option for disk partitioning because a boot/swap partition isn't needed or useful.

zerombr
clearpart --all
part / --size 3000 --fstype ext4

The issue is that some virtual HW needs some other options like /boot/efi for virt platforms that use uEFI boot or PrEP for POWER platforms which are handled well with autopart in an architecture independent manner.

It would be useful to have --noboot and --noswap options for the autopart option as a result. That way something like the following could be used for all architectures:

autopart --nolvm --noboot --noswap

Comment 1 Fedora Admin XMLRPC Client 2015-09-28 20:24:58 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 2 Peter Robinson 2017-03-02 16:48:43 UTC
Reported upstream so hopefully someone might see it there: https://github.com/rhinstaller/blivet/issues/551

Comment 3 Vendula Poncova 2017-03-09 12:14:18 UTC
This requires changes in anaconda and pykickstart.

Comment 4 Vendula Poncova 2017-04-10 11:10:43 UTC
Fixed in a pull request: https://github.com/rhinstaller/anaconda/pull/1021

Comment 5 Fedora Update System 2017-04-28 13:28:43 UTC
anaconda-26.21.4-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-f620d8c7c2

Comment 6 Fedora Update System 2017-04-30 03:52:09 UTC
anaconda-26.21.4-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-f620d8c7c2

Comment 7 Fedora Update System 2017-05-01 18:17:25 UTC
anaconda-26.21.4-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.