Bug 122088 - up2date cannot find the updated component when launched although "Check for update" reports available updates
up2date cannot find the updated component when launched although "Check for u...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks: 120092
  Show dependency treegraph
 
Reported: 2004-04-30 07:35 EDT by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-10 12:51:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot of the fault sit. (139.86 KB, image/png)
2004-04-30 07:38 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2004-04-30 07:35:44 EDT
Description of problem:
"Launch up2date" cannot find the updated component although "Check for
update" reports existing updates 

Version-Release number of selected component (if applicable):
up2date-4.3.17-1

How reproducible:

Steps to Reproduce:
1. Installed FC2 Test3 from scratch
2. Performed up2date. Update ~61 packages successfully
3. Performed check for update. Reported perl-Net-DNS-0.45-2 available
over existing perl-Net-DNS-0.31-3.2.
4. Clicked 'Launch up2date' button. No action. (Message: Your system
is fully updated. No new packages are needed)

A screenshot (.png) is available on request.
  
Actual results:
rpm -q outputs:
up2date-4.3.17-1
yum-2.0.7-0.20040416
perl-Net-DNS-0.31-3.2


Expected results:


Additional info:
Comment 1 Need Real Name 2004-04-30 07:38:49 EDT
Created attachment 99817 [details]
Screen shot of the fault sit.
Comment 2 Genadi Enchev 2004-04-30 11:42:51 EDT
I have the same problem here. The tool shows that 9 updates are
available, but when I run up2date, it says "Your system is fully
ppdated. No new packages are needed". I didn't have any problems after
the up2date right after I installed my system. 
Comment 3 Adrian Likins 2004-05-07 14:22:48 EDT
This is a bug that wont get fixed till fc3/rhel4 (and/or
a version of up2date for fc2 that understand the rpm metadata
format instead of yum repos).

Basically, in order to make multllib systems (aka x86_64 boxes
with both a x86_64 and a i386 runtime) update correctly,
cross arch updates arent allowed. In this case, the issue
is perl-Net-DNS changed from a noarch package to a arch'ed
package, so up2date wont update it. The applet, however,
doesnt know that since it doesnt handle mulitlib.


The right fix is with more metadata from the server about
not only what arch a package is, but also what arch family 
it is (aka, this package is in the x86 vector, that package
is in the x86_64 vector, etc).

That said, it should probabaly allow noarch->arch updates
anyway, since it doesnt make sense to have biarch packages
installed at the same time that way. 
Comment 4 Adrian Likins 2004-05-07 17:04:38 EDT
fix for the noarch->arch package stuff just committed to
cvs. 4.3.19 or higher should have it

i386->i686 etcwill have to wait for fc3/rhel4
Comment 5 Todd Warner 2004-08-26 21:53:57 EDT
FAILS_QA: need a test plan adrian.
Comment 6 Matthew Miller 2007-04-10 12:51:36 EDT
since there is no more up2date, marking "wontfix".

Note You need to log in before you can comment on or make changes to this bug.