Bug 1220883 - rt-4.2.11 is available
Summary: rt-4.2.11 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rt
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ralf Corsepius
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-12 18:03 UTC by Ralf Corsepius
Modified: 2015-06-30 00:16 UTC (History)
3 users (show)

Fixed In Version: rt-4.2.11-1.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-30 00:15:34 UTC
Type: Bug


Attachments (Terms of Use)

Description Ralf Corsepius 2015-05-12 18:03:12 UTC
Upstream released rt-4.2.11

Unfortunately, its test suite fails (for unknown reasons):

1. t/web/install.t

t/web/install.t .. 1/? Can't call method "find_input" on an undefined value at t/web/install.t line 69.
Can't call method "find_input" on an undefined value at t/web/install.t line 69.

#   Failed test 'no warnings'
#   at /usr/share/perl5/vendor_perl/RT/Test.pm line 1777.
# There were 1 warning(s)
#     Previous test 19 'db mysql has field DatabasePassword'
#     Can't call method "find_input" on an undefined value at t/web/install.t line 69.
#  at /usr/share/perl5/vendor_perl/Log/Dispatch/Perl.pm line 84.
#     Log::Dispatch::Perl::__ANON__("Can't call method \"find_input\" on an undefined value at t/web"...) called at /usr/share/perl5/vendor_perl/Log/Dispatch/Output.pm line 48
#     Log::Dispatch::Output::log(undef, "name", "rttest", "message", "Can't call method \"find_input\" on an undefined value at t/web"..., "level", "critical") called at /usr/share/perl5/vendor_perl/Log/Dispatch.pm line 237
#     Log::Dispatch::_log_to(Log::Dispatch=HASH(0x43ed6d0), "name", "rttest", "message", "Can't call method \"find_input\" on an undefined value at t/web"..., "level", "critical") called at /usr/share/perl5/vendor_perl/Log/Dispatch.pm line 189
#     Log::Dispatch::_log_to_outputs(Log::Dispatch=HASH(0x43ed6d0), "message", "Can't call method \"find_input\" on an undefined value at t/web"..., "level", "critical") called at /usr/share/perl5/vendor_perl/Log/Dispatch.pm line 167
#     Log::Dispatch::log(Log::Dispatch=HASH(0x43ed6d0), "level", "critical", "message", "Can't call method \"find_input\" on an undefined value at t/web"...) called at /usr/share/perl5/vendor_perl/Log/Dispatch.pm line 41
#     Log::Dispatch::__ANON__(Log::Dispatch=HASH(0x43ed6d0), "Can't call method \"find_input\" on an undefined value at t/web"...) called at /usr/share/perl5/vendor_perl/RT.pm line 389
#     RT::__ANON__("Can't call method \"find_input\" on an undefined value at t/web"...) called at t/web/install.t line 69
#
# Some tests failed or we bailed out, tmp directory '/usr/libexec/perl5-tests/rt/t/tmp/web-install.t-9EUbYmIp' is not cleaned
# Tests were run but no plan was declared and done_testing() was not seen.
# Looks like your test exited with 255 just after 20.
t/web/install.t .. Dubious, test returned 255 (wstat 65280, 0xff00)
Failed 1/20 subtests

Test Summary Report
-------------------
t/web/install.t (Wstat: 65280 Tests: 20 Failed: 1)
  Failed test:  20
  Non-zero exit status: 255
  Parse errors: No plan found in TAP output
Files=1, Tests=20,  2 wallclock secs ( 0.03 usr  0.01 sys +  2.61 cusr 0.18 csys =  2.83 CPU)
Result: FAIL




2.  t/web/make-clicky.t

t/web/make-clicky.t .. 5/?
#   Failed test '. not included in url'
#   at t/web/make-clicky.t line 19.
#          got: ..."a target="new" href="http://bestpractical.com/rt">"...
#       length: 147
#     expected: ..."a target="_blank" href="http://bestpractical.com/r"...
#       length: 150
#     strings begin to differ at char 46 (line 1 column 46)

#   Failed test '! not included in url'
#   at t/web/make-clicky.t line 19.
#          got: ..."a target="new" href="http://bestpractical.com/rt">"...
#       length: 147
#     expected: ..."a target="_blank" href="http://bestpractical.com/r"...
#       length: 150
#     strings begin to differ at char 46 (line 1 column 46)

#   Failed test '? not included in url'
#   at t/web/make-clicky.t line 19.
#          got: ..."a target="new" href="http://bestpractical.com/rt">"...
#       length: 147
#     expected: ..."a target="_blank" href="http://bestpractical.com/r"...
#       length: 150
#     strings begin to differ at char 46 (line 1 column 46)

#   Failed test ', not included in url'
#   at t/web/make-clicky.t line 19.
#          got: ..."a target="new" href="http://bestpractical.com/rt">"...
#       length: 147
#     expected: ..."a target="_blank" href="http://bestpractical.com/r"...
#       length: 150
#     strings begin to differ at char 46 (line 1 column 46)

#   Failed test 'Punctuation in middle of URL'
#   at t/web/make-clicky.t line 32.
#          got: ..."a target="new" href="http://bestpractical.com/rt/d"...
#       length: 223
#     expected: ..."a target="_blank" href="http://bestpractical.com/r"...
#       length: 226
#     strings begin to differ at char 46 (line 1 column 46)
# Some tests failed or we bailed out, tmp directory '/usr/libexec/perl5-tests/rt/t/tmp/web-make-clicky.t-u1ojegI1' is not cleaned
# Looks like you failed 5 tests of 18.
t/web/make-clicky.t .. Dubious, test returned 5 (wstat 1280, 0x500)
Failed 5/18 subtests

Test Summary Report
-------------------
t/web/make-clicky.t (Wstat: 1280 Tests: 18 Failed: 5)
  Failed tests:  7, 9, 11, 13, 15
  Non-zero exit status: 5
Files=1, Tests=18, 36 wallclock secs ( 0.03 usr  0.01 sys +  2.03 cusr 0.16 csys =  2.23 CPU)
Result: FAIL


3. t/web/ticket_preserve_basics.t

t/web/ticket_preserve_basics.t .. 6/?
#   Failed test 'field TimeEstimated-TimeUnits is the same after the form was submitted'
#   at t/web/ticket_preserve_basics.t line 47.
#          got: 'minutes'
#     expected: 'hours'
t/web/ticket_preserve_basics.t .. 11/?
#   Failed test 'field TimeWorked-TimeUnits is the same after the form was submitted'
#   at t/web/ticket_preserve_basics.t line 47.
#          got: 'minutes'
#     expected: 'hours'

#   Failed test 'field TimeLeft-TimeUnits is the same after the form was submitted'
#   at t/web/ticket_preserve_basics.t line 47.
#          got: 'minutes'
#     expected: 'hours'

#   Failed test 'field TimeEstimated is the same after the form was submitted'
#   at t/web/ticket_preserve_basics.t line 47.
#          got: '60'
#     expected: '1'

#   Failed test 'field TimeEstimated-TimeUnits is the same after the form was submitted'
#   at t/web/ticket_preserve_basics.t line 47.
#          got: 'minutes'
#     expected: 'hours'

#   Failed test 'field TimeWorked-TimeUnits is the same after the form was submitted'
#   at t/web/ticket_preserve_basics.t line 47.
#          got: 'minutes'
#     expected: 'hours'

#   Failed test 'field TimeWorked is the same after the form was submitted'
#   at t/web/ticket_preserve_basics.t line 47.
#          got: '60'
#     expected: '1'
t/web/ticket_preserve_basics.t .. 19/?
#   Failed test 'field TimeLeft is the same after the form was submitted'
#   at t/web/ticket_preserve_basics.t line 47.
#          got: '60'
#     expected: '1'

#   Failed test 'field TimeLeft-TimeUnits is the same after the form was submitted'
#   at t/web/ticket_preserve_basics.t line 47.
#          got: 'minutes'
#     expected: 'hours'
t/web/ticket_preserve_basics.t .. 35/?
#   Failed test 'field TimeEstimated-TimeUnits is the same after the Jumbo form was submitted'
#   at t/web/ticket_preserve_basics.t line 71.
#          got: 'minutes'
#     expected: 'hours'

#   Failed test 'field TimeWorked-TimeUnits is the same after the Jumbo form was submitted'
#   at t/web/ticket_preserve_basics.t line 71.
#          got: 'minutes'
#     expected: 'hours'
t/web/ticket_preserve_basics.t .. 45/?
#   Failed test 'field TimeLeft-TimeUnits is the same after the Jumbo form was submitted'
#   at t/web/ticket_preserve_basics.t line 71.
#          got: 'minutes'
#     expected: 'hours'

#   Failed test 'field TimeEstimated is the same after the Jumbo form was submitted'
#   at t/web/ticket_preserve_basics.t line 71.
#          got: '60'
#     expected: '1'

#   Failed test 'field TimeEstimated-TimeUnits is the same after the Jumbo form was submitted'
#   at t/web/ticket_preserve_basics.t line 71.
#          got: 'minutes'
#     expected: 'hours'
t/web/ticket_preserve_basics.t .. 58/?
#   Failed test 'field TimeWorked-TimeUnits is the same after the Jumbo form was submitted'
#   at t/web/ticket_preserve_basics.t line 71.
#          got: 'minutes'
#     expected: 'hours'

#   Failed test 'field TimeWorked is the same after the Jumbo form was submitted'
#   at t/web/ticket_preserve_basics.t line 71.
#          got: '60'
#     expected: '1'

#   Failed test 'field TimeLeft is the same after the Jumbo form was submitted'
#   at t/web/ticket_preserve_basics.t line 71.
#          got: '60'
#     expected: '1'

#   Failed test 'field TimeLeft-TimeUnits is the same after the Jumbo form was submitted'
#   at t/web/ticket_preserve_basics.t line 71.
#          got: 'minutes'
#     expected: 'hours'
t/web/ticket_preserve_basics.t .. 78/?
#   Failed test 'field TimeEstimated-TimeUnits is the same after the form was submitted'
#   at t/web/ticket_preserve_basics.t line 101.
#          got: 'minutes'
#     expected: 'hours'

#   Failed test 'field TimeWorked-TimeUnits is the same after the form was submitted'
#   at t/web/ticket_preserve_basics.t line 101.
#          got: 'minutes'
#     expected: 'hours'

#   Failed test 'field TimeLeft-TimeUnits is the same after the form was submitted'
#   at t/web/ticket_preserve_basics.t line 101.
#          got: 'minutes'
#     expected: 'hours'

#   Failed test 'field TimeEstimated is the same after the form was submitted'
#   at t/web/ticket_preserve_basics.t line 101.
#          got: '60'
#     expected: '1'

#   Failed test 'field TimeEstimated-TimeUnits is the same after the form was submitted'
#   at t/web/ticket_preserve_basics.t line 101.
#          got: 'minutes'
#     expected: 'hours'
t/web/ticket_preserve_basics.t .. 86/?
#   Failed test 'field TimeWorked-TimeUnits is the same after the form was submitted'
#   at t/web/ticket_preserve_basics.t line 101.
#          got: 'minutes'
#     expected: 'hours'

#   Failed test 'field TimeWorked is the same after the form was submitted'
#   at t/web/ticket_preserve_basics.t line 101.
#          got: '60'
#     expected: '1'

#   Failed test 'field TimeLeft is the same after the form was submitted'
#   at t/web/ticket_preserve_basics.t line 101.
#          got: '60'
#     expected: '1'

#   Failed test 'field TimeLeft-TimeUnits is the same after the form was submitted'
#   at t/web/ticket_preserve_basics.t line 101.
#          got: 'minutes'
#     expected: 'hours'
# Some tests failed or we bailed out, tmp directory '/usr/libexec/perl5-tests/rt/t/tmp/web-ticket_preserve_basics.t-giRFukIm' is not cleaned
# Looks like you failed 27 tests of 94.
t/web/ticket_preserve_basics.t .. Dubious, test returned 27 (wstat 6912, 0x1b00)
Failed 27/94 subtests

Test Summary Report
-------------------
t/web/ticket_preserve_basics.t (Wstat: 6912 Tests: 94 Failed: 27)
  Failed tests:  9, 11, 13, 15-20, 38, 43, 48, 53-54, 58-59
                63-64, 78, 80, 82, 84-89
  Non-zero exit status: 27
Files=1, Tests=94, 47 wallclock secs ( 0.05 usr  0.00 sys +  9.53 cusr 0.34 csys =  9.92 CPU)
Result: FAIL



1.+2. are regressions against rt-4.2.10 (These test succeed w/rt-4.2.10)
3. is a new, possibly broken test. 


Because of this, I have decided not upgrade the Fedora packages, for now.

Comment 1 Jason Tibbitts 2015-05-12 19:58:20 UTC
Unfortunately because your local patch generation procedure is not easy to duplicate (patch1 should be done by deleting the files in the spec, not with a patch) and you haven't pushed your local update to git at all, nobody else can easily look at these test suite failures.

Please consider at least pushing your changes to rawhide.  You don't have to build the new package.

Comment 2 Ralf Corsepius 2015-05-13 02:24:34 UTC
(In reply to Jason Tibbitts from comment #1)
> Unfortunately because your local patch generation procedure is not easy to
> duplicate (patch1 should be done by deleting the files in the spec, not with
> a patch) and you haven't pushed your local update to git at all, nobody else
> can easily look at these test suite failures.
I do not understand.

I am using a local git repository consistiong of imported tarballs, because the upstream git-repository lacks any (tree-) structure/trees. I the past, their release tarballs did not even match with git. I.e. these patches are against the tarballs and should be applicable against the tarball's release tags in git.

> Please consider at least pushing your changes to rawhide.  You don't have to
> build the new package.
I disagree. The contents in fedora gits should match the last Fedora packages, because pushing broken package into fedora's git would render the Fedora package un-bug-fixable.

Comment 3 Jason Tibbitts 2015-05-13 03:48:35 UTC
Maybe an srpm or something?  Unless you simply are not interested in having anyone else having a chance to look at the test suite failures.

Also, not only are you completely wrong about your statement that git has to match what's actually built at all times, but you completely ignore the concept of git branches.

Comment 4 Fedora Update System 2015-06-17 02:34:24 UTC
rt-4.2.11-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/rt-4.2.11-1.fc21

Comment 5 Fedora Update System 2015-06-17 02:34:30 UTC
rt-4.2.11-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/rt-4.2.11-1.fc22

Comment 6 Ralf Corsepius 2015-06-17 02:41:17 UTC
The issues from comment#1 seem have "automagically" healed, without me having changed anything on my testsystem or rt's packaging. I can not reproduce them anymore and don't have the faintest clues about what could have been the culprit (likely f22's initial immaturity).

Comment 7 Fedora Update System 2015-06-21 00:14:17 UTC
Package rt-4.2.11-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rt-4.2.11-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-10342/rt-4.2.11-1.fc21
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2015-06-30 00:15:34 UTC
rt-4.2.11-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2015-06-30 00:16:58 UTC
rt-4.2.11-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.