Bug 122091 - 3com driver broken for 3c905TX "Boomerang"
3com driver broken for 3c905TX "Boomerang"
Status: CLOSED DUPLICATE of bug 107389
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-30 08:10 EDT by Richard Theil
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Misc log output describing the error case (4.48 KB, text/plain)
2004-04-30 08:11 EDT, Richard Theil
no flags Details
Misc log output describing a working case (2.38 KB, text/plain)
2004-04-30 08:12 EDT, Richard Theil
no flags Details

  None (edit)
Description Richard Theil 2004-04-30 08:10:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040312 Epiphany/1.1.12

Description of problem:
I cannot get a 3com 3C905TX Fast EtherLink XL PCI ("Boomerang") Card
to work on FC2test3. Mainboard is an ECS K7VTA3 V5.0 (with latest BIOS
fixing acpi issues). The error occurs in the transmit part, the driver
seems unable to send packets. I have run a little test-matrix to
isolate the problem. The behavior is identical with "noapic acpi=off",
the "Tornado" has been tested in the same PCI slot to exclude IRQ
routing issues.

                    RH9/2.4..   Mdk10/2.6.3.4mdk  FC2-test3/2.6.5..
3C905 "Boomerang"   Works       Works             Fails
3C920 "Tornado"     untested    untested          Works



Version-Release number of selected component (if applicable):
kernel-2.6.5-1.327

How reproducible:
Always

Steps to Reproduce:
1. Install 3C905TX "Fast EtherLink XL PCI" in PCI Slot
2. Boot system to network-up state and try to ping out
3. Look in dmesg for prominent error messages from 3com driver.
    

Actual Results:  No network. Error messages in dmesg.

Expected Results:  Network. No Error messages in dmesg.

Additional info:

I attach diagnostic outputs from the relevant utilities (dmesg, lspci)
both for the non-working ("Boomerang") and working ("Tornado") case.
Comment 1 Richard Theil 2004-04-30 08:11:23 EDT
Created attachment 99818 [details]
Misc log output describing the error case
Comment 2 Richard Theil 2004-04-30 08:12:19 EDT
Created attachment 99819 [details]
Misc log output describing a working case
Comment 3 Paul Black 2004-05-20 05:27:52 EDT
I've seen the same after installing FC2 on a machine at home that has
two 3c905B TX cards (both cards affected). The thing I noticed was
that /proc/interrupts didn't show either eth0 or eth1.
Comment 4 Paul Black 2004-05-20 18:14:06 EDT
Sorry, I seem to have been mistaken about eth0 and eth1 not being
listed in /proc/interrupts. (Probably because I was playing about with
loading and unloading the modules).
Comment 5 Alan Cox 2004-05-22 12:33:27 EDT

*** This bug has been marked as a duplicate of 107389 ***
Comment 6 Red Hat Bugzilla 2006-02-21 14:02:53 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.