Bug 1220938 - calling rpm in %pre breaks buildroot construction
Summary: calling rpm in %pre breaks buildroot construction
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: man-db
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Chaloupka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
: 1220476 (view as bug list)
Depends On:
Blocks: F22FinalFreezeException 1219871
TreeView+ depends on / blocked
 
Reported: 2015-05-12 21:25 UTC by Colin Walters
Modified: 2015-09-28 15:51 UTC (History)
7 users (show)

Fixed In Version: man-db-2.6.7.1-14.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-15 21:33:07 UTC
Type: Bug


Attachments (Terms of Use)

Description Colin Walters 2015-05-12 21:25:44 UTC
See koji.fedoraproject.org/koji/taskinfo?taskID=9715399

We traced this to
http://pkgs.fedoraproject.org/cgit/man-db.git/commit/?h=f22&id=2a2705aa52ddf17f6f4afe81131ca08cd9bc8197

I patched this in
http://pkgs.fedoraproject.org/cgit/man-db.git/commit/?h=f22&id=79f2cc8d165789d3533dde625ad39b9f2744f9b5

We need to do a F22 update so that other packages like nfs-utils can be built again.

Comment 1 Fedora Blocker Bugs Application 2015-05-12 21:27:55 UTC
Proposed as a Freeze Exception for 22-final by Fedora user walters using the blocker tracking app because:

 This blocks 1219871 which is already an accepted FE, but I can't build it until this is fixed.

Comment 2 Fedora Update System 2015-05-12 21:30:08 UTC
man-db-2.7.1-4.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/man-db-2.7.1-4.fc22

Comment 3 Adam Williamson 2015-05-12 21:36:22 UTC
+1 FE.

Comment 4 Fedora Update System 2015-05-13 08:20:52 UTC
Package man-db-2.7.1-4.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing man-db-2.7.1-4.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-8109/man-db-2.7.1-4.fc22
then log in and leave karma (feedback).

Comment 5 Kalev Lember 2015-05-13 22:57:26 UTC
+1 FE

Comment 6 Cole Robinson 2015-05-13 23:07:14 UTC
*** Bug 1220476 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2015-05-13 23:15:46 UTC
man-db-2.6.7.1-14.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/man-db-2.6.7.1-14.fc21

Comment 8 Dennis Gilmore 2015-05-13 23:27:44 UTC
+1 FE

Comment 9 Adam Williamson 2015-05-14 01:20:43 UTC
That's +3, marking as accepted.

Comment 10 Colin Walters 2015-05-14 02:09:39 UTC
Please give the update karma: https://admin.fedoraproject.org/updates/FEDORA-2015-8109/man-db-2.7.1-4.fc22

Comment 11 Kamil Páral 2015-05-14 11:50:13 UTC
The package has enough karma now. Colin, have you verified that it actually fixes this bug? Or provide instructions how to do so? Thanks.

Comment 12 Colin Walters 2015-05-14 16:07:33 UTC
(In reply to Kamil Páral from comment #11)
> The package has enough karma now. Colin, have you verified that it actually
> fixes this bug? Or provide instructions how to do so? Thanks.

It fixed the rawhide build of nfs-utils for me.

Comment 13 Cole Robinson 2015-05-14 21:42:38 UTC
FWIW I can also confirm that the same man-db change fixed f22 and f21 qemu builds for me, once I added buildroot overrides for the update

Comment 14 Fedora Update System 2015-05-15 21:33:07 UTC
man-db-2.7.1-4.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2015-05-19 16:22:56 UTC
man-db-2.6.7.1-14.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.