Bug 122096 - k3b needs to know about new cdrecord syntax (for SCSI)
Summary: k3b needs to know about new cdrecord syntax (for SCSI)
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: k3b   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
: 122474 (view as bug list)
Depends On:
Blocks: FC2Target
TreeView+ depends on / blocked
 
Reported: 2004-04-30 13:42 UTC by Ralf Ertzinger
Modified: 2014-03-17 02:44 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-22 16:08:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
updated spec for k3b-0.11.9-4 (4.43 KB, patch)
2004-05-04 13:21 UTC, Justin M. Forbes
no flags Details | Diff
SCSI patch provided by notting (554 bytes, patch)
2004-05-04 13:21 UTC, Justin M. Forbes
no flags Details | Diff

Description Ralf Ertzinger 2004-04-30 13:42:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040422

Description of problem:
Due to recent changes to the kernel and cdrecord, the required syntax
to call cdrecord for SCSI drives has changed.

cdrecord must be called with "--dev=/dev/scdX" instead of "dev=X,X,X".
k3b does not know this, so all calls to cdrecord fail, making the
program pretty useless on SCSI drives.

Version-Release number of selected component (if applicable):
k3b-0.11.9-3

How reproducible:
Always

Steps to Reproduce:
1. Use k3b to burn using a SCSI drive
2.
3.
    

Actual Results:  Calls to cdrecord fail.

Expected Results:  The desired operation (recording, blanking...)

Additional info:

Comment 1 Bill Nottingham 2004-05-04 05:46:50 UTC
Please try http://people.redhat.com/notting/k3b-0.11.9-4.i386.rpm
for an untested quick hack.

Comment 2 Justin M. Forbes 2004-05-04 13:19:56 UTC
Attaching is an updated spec with the scsi patch in the rpm above, and
a fix for the i18n stuff.  Please commit if positive feedback is
received on the scsi fix.  Built and tested on i386 and x86_64 with
IDE hardware.

Comment 3 Justin M. Forbes 2004-05-04 13:21:00 UTC
Created attachment 99951 [details]
updated spec for k3b-0.11.9-4

Comment 4 Justin M. Forbes 2004-05-04 13:21:32 UTC
Created attachment 99952 [details]
SCSI patch provided by notting

Comment 5 Bill Nottingham 2004-05-05 05:50:28 UTC
*** Bug 122474 has been marked as a duplicate of this bug. ***

Comment 6 Ralf Ertzinger 2004-05-07 16:03:31 UTC
Works for me (apart from general SCSI problems, but that's not k3b's
fault)

Comment 7 Phil Schaffner 2004-05-08 18:02:07 UTC
Works to create then burn ISO image, but burn "On the fly" gives "Data
does not fit on disk error" with same source files as for ISO image.

Host: scsi0 Channel: 00 Id: 01 Lun: 00
  Vendor: YAMAHA   Model: CRW8824S         Rev: 1.00
  Type:   CD-ROM                           ANSI SCSI revision: 02


Comment 8 Mihai Maties 2004-05-31 14:18:12 UTC
Please try with the following RPM and see if the error persists: 
 
http://rpms.xcyb.org/fedora.us/k3b-0.11.10-0.fdr.2.2.src.rpm 
 
More likely the error you got is related to some bug in K3b 0.11.9. 
The new version I believe fixes it. 
 
The src.rpm above it's targeted for the fedora.us repository but it 
fits exactly into the official FC2 scheme. I mean it contains both 
the fedora.us features (conditional build with/without mp3 support) 
and the FC2 features (i18n files, k3bsetup2 disabled...). 
 
Besides that it contains the SCSI patch too. 
 

Comment 9 Justin M. Forbes 2004-05-31 15:44:54 UTC
Updated Fedora SRPMS are available at: 
http://www.linuxtx.org/rpmdrop/k3b-0.11.10-1.src.rpm
with MD5:
http://www.linuxtx.org/rpmdrop/k3b-0.11.10-1.src.rpm.md5.asc


Comment 10 Mihai Maties 2004-05-31 16:01:48 UTC
Just a few minor suggestions: 
1. Don't fix the k3bseup2.desktop file if you don't use it at all 
2. The [ -z "$QTDIR" ] check is redundant because on the first line 
of the qt.sh script we have : "if [ -z "$QTDIR" ] ; then" 
3. I see that a lot of people started to disable rpath on their 
packages (Than Ngo did it in k3b-0.11.9-4 from rawhide) 
 
And one _big_ question: 
Why did you include the i18n files in the k3b package in the first 
place and not keep the idea found in koffice, kde... etc (i.e. 
separate packages) ? 
 

Comment 11 Justin M. Forbes 2004-05-31 19:58:22 UTC
Thanks for the catch on the rpath disable.  That one should have been
pushed forward.  I still think we should fix the k3bseup2.desktop file
because if someone should want to rebuild with k3bsetup2 enabled, that
part is less obvious.  As for including i18n, there was some
discussion about this when the initial packaging for core was being
done.  The consensus seems to be, i18n should not be a seperate
package, so there it sits.

Updated SRPMS are at:
http://www.linuxtx.org/rpmdrop/k3b-0.11.10-2.src.rpm
with MD5:
http://www.linuxtx.org/rpmdrop/k3b-0.11.10-2.src.rpm.md5.asc

Comment 12 Justin M. Forbes 2004-07-22 16:08:02 UTC
fixed in FC2 updates proper. 


Note You need to log in before you can comment on or make changes to this bug.