Bug 1221000 - detach-tier status emulates like detach-tier stop
Summary: detach-tier status emulates like detach-tier stop
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: 3.7.0
Hardware: All
OS: All
urgent
urgent
Target Milestone: ---
Assignee: Mohammed Rafi KC
QA Contact: bugs@gluster.org
URL:
Whiteboard: TIERING
Depends On:
Blocks: 1260923
TreeView+ depends on / blocked
 
Reported: 2015-05-13 05:38 UTC by Mohammed Rafi KC
Modified: 2015-10-30 17:32 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.7.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-02 08:02:39 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Mohammed Rafi KC 2015-05-13 05:38:08 UTC
Description of problem:

after starting detach-tier , if we issue a detach-tier status , it shows the operation was success and nothing shows for reblance status. But later on detach-tier fails saying detach-tier was not started.

Version-Release number of selected component (if applicable):

glusterfs-3.7.0-beta2

How reproducible:


Steps to Reproduce:
1.attach a tier to a volume
2.start detach-tier
3.print detach-tier status
4.commit detach-tier


Actual results:

detach-tier commit failed

Expected results:

It should print status ,and detach-tier commit should success. 

Additional info:

Comment 1 Anand Avati 2015-05-13 05:42:02 UTC
REVIEW: http://review.gluster.org/10762 (tier/cli: detach-tier status emulate like detach-tier stop) posted (#1) for review on release-3.7 by mohammed rafi  kc (rkavunga@redhat.com)

Comment 2 Anand Avati 2015-05-31 21:25:36 UTC
COMMIT: http://review.gluster.org/10762 committed in release-3.7 by Krishnan Parthasarathi (kparthas@redhat.com) 
------
commit a2ef223f3891a58177f24207d71baa0580fccb16
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Wed May 13 10:55:14 2015 +0530

    tier/cli: detach-tier status emulate like detach-tier stop
    
    detach-tier status stops the detach-tier process, and nothing
    shows for status.
    
    Change-Id: Ibe25cb11e2f946d1389063060e4880e877dbe006
    BUG: 1221000
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/10762
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>

Comment 3 Niels de Vos 2015-06-02 08:02:39 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.1, please reopen this bug report.

glusterfs-3.7.1 has been announced on the Gluster Packaging mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.packaging/1
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.