Bug 1221045 - glusterfs-extra-xlators package is NOT being pulled in when installing the glusterfs-server
Summary: glusterfs-extra-xlators package is NOT being pulled in when installing the gl...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: build
Version: rhgs-3.1
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: ---
Assignee: Bug Updates Notification Mailing List
QA Contact: storage-qa-internal@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-13 08:20 UTC by Prasanth
Modified: 2015-06-15 13:33 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-15 13:33:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1220338 0 unspecified CLOSED unable to start the volume with the latest beta1 rpms 2021-02-22 00:41:40 UTC
Red Hat Bugzilla 1220381 0 unspecified CLOSED unable to start the volume with the latest beta1 rpms 2021-02-22 00:41:40 UTC

Internal Links: 1220338 1220381

Description Prasanth 2015-05-13 08:20:32 UTC
Description of problem:

glusterfs-extra-xlators package is NOT being pulled in when installing the glusterfs-server

Version-Release number of selected component (if applicable):
glusterfs-libs-3.7.0beta2-0.0.el6.x86_64
glusterfs-fuse-3.7.0beta2-0.0.el6.x86_64
glusterfs-client-xlators-3.7.0beta2-0.0.el6.x86_64
glusterfs-api-3.7.0beta2-0.0.el6.x86_64
glusterfs-cli-3.7.0beta2-0.0.el6.x86_64
glusterfs-server-3.7.0beta2-0.0.el6.x86_64
glusterfs-3.7.0beta2-0.0.el6.x86_64


How reproducible: 100%


Steps to Reproduce:
1. Install the glusterfs beta2 build using # yum install glusterfs-server
2.
3.

Actual results: glusterfs-extra-xlators package is NOT being pulled in when installing the glusterfs-server


Expected results: The glusterfs-extra-xlators package
should be pulled in when installing the glusterfs-server, if the former
is required for the server functionality.


Additional info:

###################
[root@dhcp42-195 build]# yum install glusterfs-server 
Loaded plugins: aliases, changelog, downloadonly, product-id, rhnplugin, security, subscription-manager, tmprepo, verify, versionlock
This system is receiving updates from RHN Classic or RHN Satellite.
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package glusterfs-server.x86_64 0:3.7.0beta2-0.0.el6 will be installed
--> Processing Dependency: glusterfs = 3.7.0beta2-0.0.el6 for package: glusterfs-server-3.7.0beta2-0.0.el6.x86_64
--> Processing Dependency: glusterfs-libs = 3.7.0beta2-0.0.el6 for package: glusterfs-server-3.7.0beta2-0.0.el6.x86_64
--> Processing Dependency: glusterfs-cli = 3.7.0beta2-0.0.el6 for package: glusterfs-server-3.7.0beta2-0.0.el6.x86_64
--> Processing Dependency: glusterfs-fuse = 3.7.0beta2-0.0.el6 for package: glusterfs-server-3.7.0beta2-0.0.el6.x86_64
--> Processing Dependency: glusterfs-client-xlators = 3.7.0beta2-0.0.el6 for package: glusterfs-server-3.7.0beta2-0.0.el6.x86_64
--> Processing Dependency: libgfapi.so.0(GFAPI_3.4.0)(64bit) for package: glusterfs-server-3.7.0beta2-0.0.el6.x86_64
--> Processing Dependency: libgfapi.so.0(GFAPI_3.4.2)(64bit) for package: glusterfs-server-3.7.0beta2-0.0.el6.x86_64
--> Processing Dependency: libgfapi.so.0(GFAPI_3.5.1)(64bit) for package: glusterfs-server-3.7.0beta2-0.0.el6.x86_64
--> Processing Dependency: libgfapi.so.0(GFAPI_3.6.0)(64bit) for package: glusterfs-server-3.7.0beta2-0.0.el6.x86_64
--> Processing Dependency: libgfapi.so.0(GFAPI_3.7.0)(64bit) for package: glusterfs-server-3.7.0beta2-0.0.el6.x86_64
--> Processing Dependency: libgfapi.so.0(GFAPI_PRIVATE_3.4.0)(64bit) for package: glusterfs-server-3.7.0beta2-0.0.el6.x86_64
--> Processing Dependency: libgfapi.so.0(GFAPI_PRIVATE_3.7.0)(64bit) for package: glusterfs-server-3.7.0beta2-0.0.el6.x86_64
--> Processing Dependency: libgfapi.so.0()(64bit) for package: glusterfs-server-3.7.0beta2-0.0.el6.x86_64
--> Processing Dependency: libgfchangelog.so.0()(64bit) for package: glusterfs-server-3.7.0beta2-0.0.el6.x86_64
--> Processing Dependency: libgfrpc.so.0()(64bit) for package: glusterfs-server-3.7.0beta2-0.0.el6.x86_64
--> Processing Dependency: libgfxdr.so.0()(64bit) for package: glusterfs-server-3.7.0beta2-0.0.el6.x86_64
--> Processing Dependency: libglusterfs.so.0()(64bit) for package: glusterfs-server-3.7.0beta2-0.0.el6.x86_64
--> Processing Dependency: liburcu-bp.so.1()(64bit) for package: glusterfs-server-3.7.0beta2-0.0.el6.x86_64
--> Processing Dependency: liburcu-cds.so.1()(64bit) for package: glusterfs-server-3.7.0beta2-0.0.el6.x86_64
--> Running transaction check
---> Package glusterfs.x86_64 0:3.7.0beta2-0.0.el6 will be installed
---> Package glusterfs-api.x86_64 0:3.7.0beta2-0.0.el6 will be installed
---> Package glusterfs-cli.x86_64 0:3.7.0beta2-0.0.el6 will be installed
---> Package glusterfs-client-xlators.x86_64 0:3.7.0beta2-0.0.el6 will be installed
---> Package glusterfs-fuse.x86_64 0:3.7.0beta2-0.0.el6 will be installed
---> Package glusterfs-libs.x86_64 0:3.7.0beta2-0.0.el6 will be installed
---> Package userspace-rcu.x86_64 0:0.7.7-1.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

============================================================================================================================================================================
 Package                          Arch           Version                       Repository                                                                              Size
============================================================================================================================================================================
Installing:
 glusterfs-server                 x86_64         3.7.0beta2-0.0.el6            download.gluster.org_pub_gluster_glusterfs_nightly_glusterfs-3.7_epel-6-x86_64         1.1 M
Installing for dependencies:
 glusterfs                        x86_64         3.7.0beta2-0.0.el6            download.gluster.org_pub_gluster_glusterfs_nightly_glusterfs-3.7_epel-6-x86_64         396 k
 glusterfs-api                    x86_64         3.7.0beta2-0.0.el6            download.gluster.org_pub_gluster_glusterfs_nightly_glusterfs-3.7_epel-6-x86_64          63 k
 glusterfs-cli                    x86_64         3.7.0beta2-0.0.el6            download.gluster.org_pub_gluster_glusterfs_nightly_glusterfs-3.7_epel-6-x86_64         145 k
 glusterfs-client-xlators         x86_64         3.7.0beta2-0.0.el6            download.gluster.org_pub_gluster_glusterfs_nightly_glusterfs-3.7_epel-6-x86_64         895 k
 glusterfs-fuse                   x86_64         3.7.0beta2-0.0.el6            download.gluster.org_pub_gluster_glusterfs_nightly_glusterfs-3.7_epel-6-x86_64         110 k
 glusterfs-libs                   x86_64         3.7.0beta2-0.0.el6            download.gluster.org_pub_gluster_glusterfs_nightly_glusterfs-3.7_epel-6-x86_64         309 k
 userspace-rcu                    x86_64         0.7.7-1.el6                   epel                                                                                    60 k

Transaction Summary
============================================================================================================================================================================
Install       8 Package(s)

Total size: 3.1 M
Installed size: 10 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Warning: RPMDB altered outside of yum.
  Installing : glusterfs-libs-3.7.0beta2-0.0.el6.x86_64                                                                                                                 1/8 
  Installing : glusterfs-client-xlators-3.7.0beta2-0.0.el6.x86_64                                                                                                       2/8 
  Installing : glusterfs-3.7.0beta2-0.0.el6.x86_64                                                                                                                      3/8 
  Installing : glusterfs-api-3.7.0beta2-0.0.el6.x86_64                                                                                                                  4/8 
  Installing : glusterfs-fuse-3.7.0beta2-0.0.el6.x86_64                                                                                                                 5/8 
  Installing : glusterfs-cli-3.7.0beta2-0.0.el6.x86_64                                                                                                                  6/8 
  Installing : userspace-rcu-0.7.7-1.el6.x86_64                                                                                                                         7/8 
  Installing : glusterfs-server-3.7.0beta2-0.0.el6.x86_64                                                                                                               8/8 
error reading information on service glusterfsd: No such file or directory
  Verifying  : userspace-rcu-0.7.7-1.el6.x86_64                                                                                                                         1/8 
  Verifying  : glusterfs-server-3.7.0beta2-0.0.el6.x86_64                                                                                                               2/8 
  Verifying  : glusterfs-api-3.7.0beta2-0.0.el6.x86_64                                                                                                                  3/8 
  Verifying  : glusterfs-libs-3.7.0beta2-0.0.el6.x86_64                                                                                                                 4/8 
  Verifying  : glusterfs-client-xlators-3.7.0beta2-0.0.el6.x86_64                                                                                                       5/8 
  Verifying  : glusterfs-cli-3.7.0beta2-0.0.el6.x86_64                                                                                                                  6/8 
  Verifying  : glusterfs-3.7.0beta2-0.0.el6.x86_64                                                                                                                      7/8 
  Verifying  : glusterfs-fuse-3.7.0beta2-0.0.el6.x86_64                                                                                                                 8/8 

Installed:
  glusterfs-server.x86_64 0:3.7.0beta2-0.0.el6                                                                                                                              

Dependency Installed:
  glusterfs.x86_64 0:3.7.0beta2-0.0.el6                          glusterfs-api.x86_64 0:3.7.0beta2-0.0.el6            glusterfs-cli.x86_64 0:3.7.0beta2-0.0.el6           
  glusterfs-client-xlators.x86_64 0:3.7.0beta2-0.0.el6           glusterfs-fuse.x86_64 0:3.7.0beta2-0.0.el6           glusterfs-libs.x86_64 0:3.7.0beta2-0.0.el6          
  userspace-rcu.x86_64 0:0.7.7-1.el6                            

Complete!
###################

Comment 1 Rejy M Cyriac 2015-05-13 08:42:05 UTC
It looks like the patch

http://review.gluster.org/#/c/10753

would make the glusterfs-extra-xlators package not essential for glusterfs server functionality

Comment 2 SATHEESARAN 2015-05-13 09:03:56 UTC
(In reply to Rejy M Cyriac from comment #1)
> It looks like the patch
> 
> http://review.gluster.org/#/c/10753
> 
> would make the glusterfs-extra-xlators package not essential for glusterfs
> server functionality

Yes, marker.so is incorrectly provided by glusterfs-extra-xlators, it will be actually provided by glusterfs-server package. There is already a bug tracking this change

Comment 4 Rejy M Cyriac 2015-05-19 12:30:22 UTC
From recent discussions, it appears that the glusterfs-extra-xlators package is not required downstream

Comment 7 SATHEESARAN 2015-05-19 14:46:20 UTC
(In reply to Rejy M Cyriac from comment #4)
> From recent discussions, it appears that the glusterfs-extra-xlators package
> is not required downstream

In that case, I feel this bug could be CLOSED as NOTABUG.
Any suggestions/justification to keep it open ?

Comment 8 Niels de Vos 2015-06-15 13:17:31 UTC
(In reply to SATHEESARAN from comment #7)
> (In reply to Rejy M Cyriac from comment #4)
> > From recent discussions, it appears that the glusterfs-extra-xlators package
> > is not required downstream
> 
> In that case, I feel this bug could be CLOSED as NOTABUG.
> Any suggestions/justification to keep it open ?

Indeed, glusterfs-extras-xlators is only useful for developers and users doing certain tests. The xlators the package contains are not configurable through the glusterfs-cli, and require manual editing of .vol files (not supported for RHGS customers).

Prasanth, do you still hit problems when glusterfs-extra-xlators is not installed on a Gluster server? If not, please close this bug.

Comment 9 Prasanth 2015-06-15 13:33:54 UTC
(In reply to Niels de Vos from comment #8)
> (In reply to SATHEESARAN from comment #7)
> > (In reply to Rejy M Cyriac from comment #4)
> > > From recent discussions, it appears that the glusterfs-extra-xlators package
> > > is not required downstream
> > 
> > In that case, I feel this bug could be CLOSED as NOTABUG.
> > Any suggestions/justification to keep it open ?
> 
> Indeed, glusterfs-extras-xlators is only useful for developers and users
> doing certain tests. The xlators the package contains are not configurable
> through the glusterfs-cli, and require manual editing of .vol files (not
> supported for RHGS customers).
> 
> Prasanth, do you still hit problems when glusterfs-extra-xlators is not
> installed on a Gluster server? If not, please close this bug.

Based on above comment, closing this bug.


Note You need to log in before you can comment on or make changes to this bug.