Bug 122106 - Adaptec SCSI Controller not Detected
Adaptec SCSI Controller not Detected
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-30 11:30 EDT by Dave Burgess
Modified: 2015-01-04 17:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-08 11:48:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Burgess 2004-04-30 11:30:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040210 Firefox/0.8

Description of problem:
When attempting to install Fedora Core 2 Test 3 on my Asus A7N8X-X
motherboard it will never detect my Adaptec SCSI controllers.  I am
NOT running RAID I have one controller for my scanner and another for
all my harddrives.

When attempting to install it will detect my internal USB reader
(multiformat unit) and load the USB mass storage driver then show a
blue screen and stop.

Attempting to use "linux noprobe" allows me to tell it to load the
aic7xxx driver (which it does - I think) it then load moves to the
blue screen and stops.  BTW it loads the USB mass storage driver
automatically no matter what I do.

I have to physically disconect (from the motherboard) the USB reader
and then use linux noprobe to force loading of the aic7xxx driver.  It
will NOT auto detect with or without the USB reader.  At this point I
get the usual "do ya wanna do a media check" screen and I'm away to
the races.

BTW All previous Redhat and Fedora Releases (test or not) detected
these cards (2940AU and 2940AWU) just fine

Also I have no I20 devices (as far as I know)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot from CD or DVD
2. BOOM
3.
    

Additional info:
Comment 1 Jeremy Katz 2004-05-03 10:12:11 EDT
Does it work if you boot with 'linux nousbstorage'?
Comment 2 Dave Burgess 2004-05-03 16:39:08 EDT
When I boot with "linux nousbstorage" it correctly does not load the
usbmassstorage driver and does indeed load the aic7xxx driver however
it no longer detects my usb mouse.  It's a MS Intellimouse Explorer
USB and PS/2 Compatible.

The SCSI cards are:

AHA-2940UW Bios 2.20.0
AHA-2940U2W Bios 2.57.2

The scanner is on the 2940UW and all my drives are on the 2940U2W with
the exception of my DVD (Pioneer A105) it's EIDE.
Comment 3 Dave Jones 2004-12-08 01:19:12 EST
any better with current updates / trees ?
Comment 4 Dave Burgess 2004-12-08 05:56:03 EST
(In reply to comment #3)
> any better with current updates / trees ?

It was fine in the final FC 2 and in all the FC 3 betas and then in teh FC 3
release the SCSI cards are deteced although it takes over one minute for teh
kernel to finish detecting them and move on.  The usbstaorage bug was
reintroduced with FC 3 final.

With a USB multiformat reader installed I either need to physically unplug it
from the motherboard or use the "nousbstorage" kernel option to prevent it
hanging during boot.

So to make a short story longer - this particular SCSI problem seems to be
corrected.
Comment 5 Dave Jones 2004-12-08 11:48:25 EST
ok, feel free to open new ones for the other bugs, (but check if theres
something similar first, and add to those if necessary)

thanks

Note You need to log in before you can comment on or make changes to this bug.