This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 122113 - OOo build lacks rpath.
OOo build lacks rpath.
Status: CLOSED DUPLICATE of bug 102287
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks: fedora-ppc FC3Target FC4Target
  Show dependency treegraph
 
Reported: 2004-04-30 12:54 EDT by David Woodhouse
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-11 05:58:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2004-04-30 12:54:58 EDT
Description of problem:
On PPC all OOo objects, and on i386 at least some libraries are
lacking rpath. This prevents successful prelinking unless
/usr/lib/ooo-1.1/program is added to LD_LIBRARY_PATH or ld.so.conf

On i386 it's only libicui18n.so libicule.so libicuuc.so

Note also that we should be changing all instances of '-Wl,-rpath,xyz'
to '-Wl,--enable-new-dtags,-rpath,xyz'
Comment 1 Caolan McNamara 2004-11-02 10:53:47 EST
Just added a patch I reckon will work to #rh102287# on this topic.
This bug is really a duplicate of that I reckon.
Comment 2 David Woodhouse 2004-11-03 11:45:01 EST
/usr/lib/ooo-1.1/program/soffice.bin: error while loading shared
libraries: libvcl645lp.so: cannot open shared object file: No such
file or directory
Comment 3 Dan Williams 2004-11-08 09:56:47 EST
Will dupe to Bug 102287 then since that takes care of this.

*** This bug has been marked as a duplicate of 102287 ***
Comment 4 Caolan McNamara 2004-11-11 05:58:34 EST
close as duplicate

Note You need to log in before you can comment on or make changes to this bug.