Bug 1221168 - gtk apps unable to open window with X11 forwarding over ssh
Summary: gtk apps unable to open window with X11 forwarding over ssh
Keywords:
Status: CLOSED DUPLICATE of bug 1174257
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk3
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-13 12:09 UTC by Richard W.M. Jones
Modified: 2015-05-27 18:59 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-27 18:59:02 UTC


Attachments (Terms of Use)
strace-qemu.log (212.58 KB, text/plain)
2015-05-13 12:14 UTC, Richard W.M. Jones
no flags Details

Description Richard W.M. Jones 2015-05-13 12:09:55 UTC
Description of problem:

Simply run the following command on a remote machine where you
have enabled X forwarding over SSH:

  $ qemu-system-x86_64 -no-user-config -nodefaults -display gtk -vga cirrus

Of course there is no OS so it'll just get stuck in the BIOS.

Question: Is it able to open a window?

For Rawhide, no.  The process just gets stuck with no activity
(strace shows no system calls being made).

Version-Release number of selected component (if applicable):

Fails with:
qemu-2.3.0-3.fc23.x86_64
qemu-2.3.0-2.fc23.x86_64

Works with:
qemu compiled from source (968bb75c348a40)

How reproducible:

100%

Steps to Reproduce:
1. Run the command above on a remote machine.

Comment 1 Richard W.M. Jones 2015-05-13 12:14:03 UTC
Created attachment 1025038 [details]
strace-qemu.log

strace of process

Comment 2 Cole Robinson 2015-05-13 14:40:22 UTC
Does any gtk app work? Try bare 'virt-viewer' or something

Comment 3 Richard W.M. Jones 2015-05-13 15:06:26 UTC
Very good point.  I tested it with xterm, which of course isn't a gtk app.

virt-viewer *does* hang.  So it's something in gtk.  Reassigning ...

Comment 4 Richard W.M. Jones 2015-05-27 18:59:02 UTC
Turns out to be bug 1174257.  The workaround is to set
LIBGL_DRI3_DISABLE=1

*** This bug has been marked as a duplicate of bug 1174257 ***


Note You need to log in before you can comment on or make changes to this bug.