Bug 122131 - ps command doesn't support by CPU listing of processes
Summary: ps command doesn't support by CPU listing of processes
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: procps (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-04-30 18:43 UTC by Sean Bruno
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-10 15:27:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sean Bruno 2004-04-30 18:43:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040422

Description of problem:
In previous releases of "ps" you could display processes with the CPU
that they were running on by using the --format=cpu command.

That ability seems to have been intentionally removed by the procps
folks as it is no longer in the --help or the "man" page for ps.

It was in the 2.x versions of procps, so it has been removed
intentionally for some reason.

Version-Release number of selected component (if applicable):
procps-3.2.0-1.1

How reproducible:
Always

Steps to Reproduce:
1. run ps --format=cpu
2.
3.
    

Actual Results:  all processes listed with a "-" instead of the number
of the CPU that they are running on:

[sean@homebox sean]$ ps -ef --format=cpu
Warning: bad syntax, perhaps a bogus '-'? See
http://procps.sf.net/faq.html
CPU
  -
  -
  -
  -
  -
  -
  -


Expected Results:  It should list the CPU that it is running on, this
works in the 2.x versions of procps.

Additional info:

I am putting this in as a Feature Request as it is a loss of
functionality not a bug per se.  

I hope to get the procps folks to put this back into their program as
it is a very useful tool for troubleshooting thread performance issues.

Comment 1 Sean Bruno 2004-05-10 15:27:49 UTC
I asked the procps folks for their assistance on this one.  There is
an alternative --format option "psr" that works just as well and
solves this item.

Go ahead and close this!  


Note You need to log in before you can comment on or make changes to this bug.