Bug 1221310 - undefined symbol: ssh_forward_listen
undefined symbol: ssh_forward_listen
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libssh (Show other bugs)
22
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Andreas Schneider
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-05-13 12:55 EDT by Andrey Amado
Modified: 2015-07-14 11:28 EDT (History)
5 users (show)

See Also:
Fixed In Version: libssh-0.7.1-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-14 11:28:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrey Amado 2015-05-13 12:55:14 EDT
Description of problem:

I tried connecto to remote ssh server with ssh-key and the x2goclient crash.


Version-Release number of selected component (if applicable):
x2goclient-4.0.3.2-1.fc22.x86_64
fuse-sshfs-2.5-1.fc22.x86_64
openssh-6.8p1-5.fc22.x86_64
libssh2-1.5.0-1.fc22.x86_64
libssh-0.7.0-1.fc22.x86_64
openssh-clients-6.8p1-5.fc22.x86_64
openssh-server-6.8p1-5.fc22.x86_64


How reproducible:


Steps to Reproduce:
1. Open on konsole x2goclient
2. Click on the connection to server (its contain a ssh-key to authenticate)
3. crash to next error.

Actual results:
[xxx@xxx ~]$ x2goclient --debug
x2go-INFO-1> "Starting x2goclient..."
x2go-INFO-4> "Traductor: :/x2goclient_es_mx instalado."
x2go-INFO-5> "Traductor: :/qt_es_MX instalado."
x2go-INFO-3> "Cliente X2Go iniciado."
x2go-DEBUG-../onmainwindow.cpp:495> "$HOME=/home/xxxx"
x2go-DEBUG-../onmainwindow.cpp:2123> Reading 4 sessions from config file.
x2go-DEBUG-../onmainwindow.cpp:2668> Starting session via smartcard, ssh-agent or kerberos token.
x2go-INFO-8> "Iniciando conección con el servidor: xx.xx.xx.xx:22"
x2go-DEBUG-../onmainwindow.cpp:2702> Start new ssh connection to server:"xx.xxx.xxx.xx":"22" krbLogin: false
x2go-DEBUG-../sshmasterconnection.cpp:202> starting ssh connection without kerberos authentication

x2go-DEBUG-../sshmasterconnection.cpp:206> SshMasterConnection, instance SshMasterConnection(0x10507a0)  created 
x2go-DEBUG-../sshmasterconnection.cpp:442> SshMasterConnection, instance SshMasterConnection(0x10507a0)  entering thread 
x2go-DEBUG-../sshmasterconnection.cpp:478> libSsh not inited yet, initting

x2go-DEBUG-../sshmasterconnection.cpp:789> cserverAuth
 
x2go-DEBUG-../sshmasterconnection.cpp:804> state: 1

x2go-DEBUG-../sshmasterconnection.cpp:654> user auth OK

x2go-DEBUG-../onmainwindow.cpp:2797> SSH connection established.
x2go-DEBUG-../onmainwindow.cpp:3060> Continue normal x2go session
x2go-DEBUG-../sshprocess.cpp:189> executing remote command via SshProcess object (0): "export HOSTNAME && x2golistsessions"

x2go-DEBUG-../sshmasterconnection.cpp:1434> creating new channel

x2go-DEBUG-../sshmasterconnection.cpp:1438> new channel:0x7f4018013400

x2go-DEBUG-../sshmasterconnection.cpp:1469> executing remote: "sh -c 'echo X2GODATABEGIN:3edc9428-0b0c-4b49-9bc9-e95f836a86b5; PATH=/usr/local/bin:/usr/bin:/bin export HOSTNAME && x2golistsessions; echo X2GODATAEND:3edc9428-0b0c-4b49-9bc9-e95f836a86b5;'"

x2go-DEBUG-../sshmasterconnection.cpp:1492>  new exec channel created

x2go-DEBUG-../sshmasterconnection.cpp:1596> EOF ON CHANNEL 0x7f4018013400 (SshProcess: 0)

x2go-DEBUG-../sshmasterconnection.cpp:1664> eof sent

x2go-DEBUG-../sshmasterconnection.cpp:1668> channel closed

x2go-DEBUG-../sshprocess.cpp:449> ssh finished: true - "" (0).

x2go-DEBUG-../onmainwindow.cpp:3404> ""
x2go-DEBUG-../onmainwindow.cpp:3923> Executing remote command: "X2GODPI=96 x2gostartagent 1200x700 adsl 16m-jpeg-9 unix-kde-depth_24 es auto 1 D GNOME both"
x2go-DEBUG-../sshprocess.cpp:189> executing remote command via SshProcess object (1): "X2GODPI=96 x2gostartagent 1200x700 adsl 16m-jpeg-9 unix-kde-depth_24 es auto 1 D GNOME both"

x2go-DEBUG-../sshmasterconnection.cpp:1434> creating new channel

x2go-DEBUG-../sshmasterconnection.cpp:1438> new channel:0x7f4018013400

x2go-DEBUG-../sshmasterconnection.cpp:1469> executing remote: "sh -c 'echo X2GODATABEGIN:bd2509a6-c889-4426-8109-4eb948090053; PATH=/usr/local/bin:/usr/bin:/bin X2GODPI=96 x2gostartagent 1200x700 adsl 16m-jpeg-9 unix-kde-depth_24 es auto 1 D GNOME both; echo X2GODATAEND:bd2509a6-c889-4426-8109-4eb948090053;'"

x2go-DEBUG-../sshmasterconnection.cpp:1492>  new exec channel created

x2go-DEBUG-../sshmasterconnection.cpp:1596> EOF ON CHANNEL 0x7f4018013400 (SshProcess: 1)

x2go-DEBUG-../sshmasterconnection.cpp:1664> eof sent

x2go-DEBUG-../sshmasterconnection.cpp:1668> channel closed

x2go-DEBUG-../sshprocess.cpp:449> ssh finished: true - "51
89661b87bff3c8270639fe8fb72dce56
4173
xx-51-1431533712_stDGNOME_dp24
30006
30007
30008
" (1).

x2go-DEBUG-../onmainwindow.cpp:4727> Agent output: "51
89661b87bff3c8270639fe8fb72dce56
4173
xxx-51-1431533712_stDGNOME_dp24
30006
30007
30008
"
x2go-DEBUG-../sshprocess.cpp:294> Starting tunnel via SshProcess object (2): "localhost":30006 -> "localhost":31006

x2go-DEBUG-../onmainwindow.cpp:5337> "Starting NX proxy, command: nxproxy -S nx/nx,options=/home/xxxxx/.x2go/S-xxx-51-1431533712_stDGNOME_dp24/options:51"
x2go-DEBUG-../sshprocess.cpp:157> Direct tunnel: waiting for connections on "localhost":31006

x2go-DEBUG-../sshprocess.cpp:189> executing remote command via SshProcess object (3): "echo "default-server=localhost:30007"> $HOME/.x2go/C-xxxxx-51-1431533712_stDGNOME_dp24/.pulse-client.conf;echo "cookie-file=.x2go/C-xxxx-51-1431533712_stDGNOME_dp24/.pulse-cookie">> $HOME/.x2go/C-xxxx-51-1431533712_stDGNOME_dp24/.pulse-client.conf"

x2go-DEBUG-../sshmasterconnection.cpp:1434> creating new channel

x2go-DEBUG-../sshmasterconnection.cpp:1438> new channel:0x7f4018013400

x2go-DEBUG-../sshmasterconnection.cpp:1469> executing remote: "sh -c 'echo X2GODATABEGIN:f54bd3b2-dc92-4e5d-92d6-423c62a4104f; PATH=/usr/local/bin:/usr/bin:/bin echo "default-server=localhost:30007"> $HOME/.x2go/C-seturex-51-1431533712_stDGNOME_dp24/.pulse-client.conf;echo "cookie-file=.x2go/C-xxxx-51-1431533712_stDGNOME_dp24/.pulse-cookie">> $HOME/.x2go/C-xxxxx-51-1431533712_stDGNOME_dp24/.pulse-client.conf; echo X2GODATAEND:f54bd3b2-dc92-4e5d-92d6-423c62a4104f;'"

x2go-DEBUG-../sshprocess.cpp:244> copying file via SshProcess object (4): "/home/xxxx/.config/pulse/cookie" -> "$HOME/.x2go/C-xxxx-51-1431533712_stDGNOME_dp24/.pulse-cookie"

x2go-DEBUG-../sshprocess.cpp:294> Starting tunnel via SshProcess object (5): "localhost":30007 -> "127.0.0.1":4713

x2go-DEBUG-../sshmasterconnection.cpp:388> Requesting reverse tunnel from port 30007 to 4713
x2go-DEBUG-../onmainwindow.cpp:5662> Proxy wrote on stderr: "
NXPROXY - Version 3.5.0

Copyright (C) 2001, 2010 NoMachine.
See http://www.nomachine.com/ for more information.

Info: Proxy running in client mode with pid '6388'.
Session: Starting session at 'Wed May 13 10:43:13 2015'.
Info: Using abstract X11 socket in kernel namespace for accessing DISPLAY=:0.
Info: Connecting to remote host 'localhost:31006'.
Info: Connection to remote proxy 'localhost:31006' established.
"
x2go-DEBUG-../sshprocess.cpp:109> new tcp connection

x2go-DEBUG-../sshprocess.cpp:114> new socket:15

x2go-DEBUG-../sshmasterconnection.cpp:1492>  new exec channel created

x2goclient: symbol lookup error: x2goclient: undefined symbol: ssh_forward_listen


Expected results:

Connection successful.   


Additional info:

Remote server is Red Hat Enterprise Linux Server release 6.4 (Santiago)
ssh version: sshfs-2.5-23.1.x86_64
libssh2-1.4.2-1.el6.x86_64
openssh-askpass-5.3p1-104.el6_6.1.x86_64
openssh-5.3p1-104.el6_6.1.x86_64
libssh4-0.6.5-23.1.x86_64
openssh-clients-5.3p1-104.el6_6.1.x86_64
openssh-server-5.3p1-104.el6_6.1.x86_64
Comment 1 Orion Poplawski 2015-05-19 22:10:05 EDT
Upstream reports:

https://red.libssh.org/issues/194
http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=870

looks like essentially a libssh bug.
Comment 2 Scott Dowdle 2015-05-20 18:31:03 EDT
Yes, see upstream bug report and the patched supplied with it:

https://red.libssh.org/issues/194
Comment 3 Fedora Update System 2015-05-21 15:42:52 EDT
libssh-0.7.0-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/libssh-0.7.0-2.fc22
Comment 4 Andrey Amado 2015-06-21 16:43:29 EDT
(In reply to Fedora Update System from comment #3)
> libssh-0.7.0-2.fc22 has been submitted as an update for Fedora 22.
> https://admin.fedoraproject.org/updates/libssh-0.7.0-2.fc22

Hi every one, great this packages works perfect.. bug for me is close..
Thanks..
Comment 5 Fedora Update System 2015-06-30 04:15:50 EDT
libssh-0.7.1-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/libssh-0.7.1-1.fc22
Comment 6 Fedora Update System 2015-06-30 16:15:28 EDT
Package libssh-0.7.1-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libssh-0.7.1-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-10962/libssh-0.7.1-1.fc22
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2015-07-14 11:28:43 EDT
libssh-0.7.1-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.