Bug 1221312 - After upgrading RHEV-M to 3.5.1 and RHEV-H to 7.1, fencing with ilo4 no longer works
Summary: After upgrading RHEV-M to 3.5.1 and RHEV-H to 7.1, fencing with ilo4 no longe...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.1
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Eli Mesika
QA Contact: Petr Matyáš
URL:
Whiteboard:
: 1221316 (view as bug list)
Depends On: 1219620
Blocks: 1225082
TreeView+ depends on / blocked
 
Reported: 2015-05-13 16:57 UTC by Bimal Chollera
Modified: 2019-08-15 04:35 UTC (History)
15 users (show)

Fixed In Version: OVIRT 3.6.0-3
Doc Type: Bug Fix
Doc Text:
The fence-agents package on Red Hat Enterprise Linux dropped support of boolean flags being supplied to various scripts from the command line without a value. As a result, all existing flags stored in the database have been changed to explicitly set the boolean flag value. This ensures old settings of PM definitions that have the old format now work after upgrade.
Clone Of:
: 1225082 (view as bug list)
Environment:
Last Closed: 2016-03-09 21:06:32 UTC
oVirt Team: Infra


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 41103 None None None Never

Description Bimal Chollera 2015-05-13 16:57:37 UTC
Description of problem:

After upgrading RHEV-M from 3.4.5 to 3.5.1 and the hypervisor hosts from RHEV-H 6.6 to 7.1, fencing with ilo4 no longer works.


Version-Release number of selected component (if applicable):

rhevm-3.5.1-0.4.el6ev.noarch

Red Hat Enterprise Virtualization Hypervisor 7.1 (20150420.0.el7ev)
vdsm-4.16.13.1-1.el7ev.x86_64   
fence-agents-all-4.0.11-11.el7_1.x86_64

How reproducible:

Steps to Reproduce:

1.  Add 2 hosts to engine configured with ilo4 power management
2.  Click Test button on Power Management page.
3.  Error reported:

Failed: Unable to obtain correct plug status or plug is not available

Actual results:

Failed: Unable to obtain correct plug status or plug is not available

vdsm log:

Thread-1207::DEBUG::2015-05-08 10:33:53,291::utils::759::root::(execCmd) FAILED: <err> = 'Failed: Unable to obtain correct plug status or plug is not available\n\n\n'; <rc> = 1
Thread-1207::DEBUG::2015-05-08 10:33:53,291::API::1164::vds::(fence) rc 1 inp agent=fence_ipmilan
ipaddr=XXX.XX.XX.XX
login=root
action=status
passwd=XXXX
power_wait=4
lanplus out [] err ['Failed: Unable to obtain correct plug status or plug is not available', '', '']

Expected results:

Fencing shouldn't fail and error messages shouldn't be reported.
Before the update, all was working.

Additional info:

HP Blades (ilo4 fence method)

Comment 1 Bimal Chollera 2015-05-13 17:20:04 UTC
After adding lanplus=1 in the Options box (Host tab -> Select Host -> Edit -> Click on Power Management -> in the Options box) in the Power Management Setup, the Power Management tests and fencing test were successful. The error message also was not reported.

Comment 6 Bimal Chollera 2015-05-13 17:40:08 UTC
*** Bug 1221316 has been marked as a duplicate of this bug. ***

Comment 13 errata-xmlrpc 2016-03-09 21:06:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.