Bug 1221368 - FF38 is missing splice workaround specific to el5
Summary: FF38 is missing splice workaround specific to el5
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: firefox
Version: 5.11
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Martin Stransky
QA Contact: Desktop QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1331691
TreeView+ depends on / blocked
 
Reported: 2015-05-13 21:14 UTC by Michael Lampe
Modified: 2016-04-29 12:32 UTC (History)
8 users (show)

(edit)
Clone Of:
: 1331691 (view as bug list)
(edit)
Last Closed: 2015-05-25 11:42:51 UTC


Attachments (Terms of Use)
rhbz-1150082.patch (745 bytes, patch)
2015-05-13 21:14 UTC, Michael Lampe
no flags Details | Diff

Description Michael Lampe 2015-05-13 21:14:23 UTC
Created attachment 1025187 [details]
rhbz-1150082.patch

Without it, FF38 is basically unsusable. It hangs all over the place, you cannot download and save files, etc.

See https://bugzilla.redhat.com/show_bug.cgi?id=1150082 for details and workaround. Patch also attached.

The bug is in el5's splice(), not in firefox. So obviously, upstream cannot have fixed it. The patch is still needed.

I can confirm that a build with this patch applied works fine as expected.

Comment 2 Martin Stransky 2015-05-18 18:22:55 UTC
Thanks, added to 38.0.1-2

Comment 3 Simon Matter 2015-05-21 13:46:12 UTC
Will firefox-38.0.1-2 be published as an update? The current version is useless on EL5.

Comment 4 Akemi Yagi 2015-05-21 14:31:38 UTC
As a temporary measure, you can use the patched version offered by a CentOS developer:

http://people.centos.org/tru/firefox-38.0-4.el5.centos.bz1221368/

Comment 5 Martin Stransky 2015-05-25 05:28:18 UTC
Is going to be released as a part of fix https://bugzilla.redhat.com/show_bug.cgi?id=1221600

Comment 6 Martin Stransky 2015-05-25 11:42:51 UTC
Should be fixed as a part of a 38.0.1 update, available in
https://rhn.redhat.com/errata/RHBA-2015-1026.html

Comment 7 Johnny Hughes 2016-04-28 23:39:48 UTC
It looks like this patch was again removed in firefox 45.0.1.  The patch will apply to the el5 firefox sources.  

There has be a report of a problem with the el5 build in CentOS-5.11 (firefox 45.0.1) where the issue is present:

https://lists.centos.org/pipermail/centos/2016-April/159012.html

I am currently building a test firefox-45.0.1 rpm set with the rhbz-1150082.patch to see if it fixes the issue.

Comment 8 Martin Stransky 2016-04-29 09:16:57 UTC
Yes, the patch is missing in the rebased package - we need to ship the patch again.

Comment 9 Simon Matter 2016-04-29 09:21:38 UTC
As a side note, I guess the same is true for rhbz-1173156. @Martin, could you also check https://bugzilla.redhat.com/show_bug.cgi?id=1173156 for the next update?

Comment 10 Simon Matter 2016-04-29 11:52:44 UTC
Just to confirm: I did an x86_64 build now with both rhbz-1150082.patch and rhbz-1173156.patch included and it seems to work fine for me.

Comment 11 Johnny Hughes 2016-04-29 12:32:55 UTC
I have built and published temporary packages for CentOS Linux here, we will not actually release those and will instead wait until a fix is released.  Here are the temporary packages for anyone who wants them in the interim:

http://people.centos.org/hughesjr/firefox-45.1.0-1.1.el5.centos/

That only has the rhbz-1150082.patch (this issue) and not the second rhbz-1173156.patch.


Note You need to log in before you can comment on or make changes to this bug.