Bug 1221477 - The tiering feature requires counters.
Summary: The tiering feature requires counters.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: 3.7.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
Assignee: Mohammed Rafi KC
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On: 1213063
Blocks: 1227187 1260923
TreeView+ depends on / blocked
 
Reported: 2015-05-14 06:50 UTC by Mohammed Rafi KC
Modified: 2015-12-01 16:45 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.7.1
Doc Type: Bug Fix
Doc Text:
Clone Of: 1213063
: 1227187 (view as bug list)
Environment:
Last Closed: 2015-06-02 08:02:46 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Mohammed Rafi KC 2015-05-14 06:50:19 UTC
+++ This bug was initially created as a clone of Bug #1213063 +++

Add support for counters for tiered volumes to show #promoted / #demoted files.

--- Additional comment from Anand Avati on 2015-04-18 07:59:34 EDT ---

REVIEW: http://review.gluster.org/10292 (glusterd: add counter support for tiered volumes) posted (#1) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Anand Avati on 2015-04-21 16:52:09 EDT ---

REVIEW: http://review.gluster.org/10292 (glusterd: add counter support for tiered volumes) posted (#2) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Anand Avati on 2015-04-27 12:59:19 EDT ---

REVIEW: http://review.gluster.org/10292 (glusterd: add counter support for tiered volumes) posted (#3) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Anand Avati on 2015-04-29 15:39:22 EDT ---

REVIEW: http://review.gluster.org/10292 (glusterd: add counter support for tiered volumes) posted (#4) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Anand Avati on 2015-05-04 11:48:09 EDT ---

REVIEW: http://review.gluster.org/10292 (glusterd: add counter support for tiered volumes) posted (#6) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

--- Additional comment from Anand Avati on 2015-05-06 12:44:03 EDT ---

REVIEW: http://review.gluster.org/10292 (glusterd: add counter support for tiered volumes) posted (#7) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Anand Avati on 2015-05-06 12:47:55 EDT ---

REVIEW: http://review.gluster.org/10292 (glusterd: add counter support for tiered volumes) posted (#8) for review on master by Dan Lambright (dlambrig@redhat.com)

--- Additional comment from Anand Avati on 2015-05-07 09:31:53 EDT ---

REVIEW: http://review.gluster.org/10292 (glusterd: add counter support for tiered volumes) posted (#9) for review on master by Dan Lambright (dlambrig@redhat.com)

Comment 1 Anand Avati 2015-05-14 06:55:07 UTC
REVIEW: http://review.gluster.org/10775 (glusterd: add counter support for tiered volumes) posted (#1) for review on release-3.7 by mohammed rafi  kc (rkavunga@redhat.com)

Comment 2 Anand Avati 2015-05-28 07:25:36 UTC
COMMIT: http://review.gluster.org/10775 committed in release-3.7 by Krishnan Parthasarathi (kparthas@redhat.com) 
------
commit 4e2bc057ee5afb412d9056dc71a6bb959fb11df6
Author: Dan Lambright <dlambrig@redhat.com>
Date:   Thu Apr 16 05:21:16 2015 +0100

    glusterd: add counter support for tiered volumes
    
            back port of http://review.gluster.org/10292
    
    This fix adds support to view the number of promoted or demoted
    files from the cli. The mechanism is isolmorphic to checking
    the status of volumes being rebalanced.
    
    gluster volume rebalance <vol> tier status
    
     >Change-Id: I1b11ca27355ceec36c488967c23531202030e205
     >BUG: 1213063
     >Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
     >Signed-off-by: Dan Lambright <dlambrig@redhat.com>
     >Reviewed-on: http://review.gluster.org/10292
     >Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
     >Tested-by: Gluster Build System <jenkins@build.gluster.com>
    
    Change-Id: I543e886f17132b544274c83fdecca5a8da9d092a
    BUG: 1221477
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Signed-off-by: Dan Lambright <dlambrig@redhat.com>
    Reviewed-on: http://review.gluster.org/10775
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>

Comment 3 Niels de Vos 2015-06-02 08:02:46 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.1, please reopen this bug report.

glusterfs-3.7.1 has been announced on the Gluster Packaging mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.packaging/1
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.