Bug 1221503 - DHT Rebalance : Misleading log messages for linkfiles
Summary: DHT Rebalance : Misleading log messages for linkfiles
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Susant Kumar Palai
QA Contact:
URL:
Whiteboard:
Depends On: 1220329
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-14 08:28 UTC by Susant Kumar Palai
Modified: 2015-06-02 08:24 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.7.1
Doc Type: Bug Fix
Doc Text:
Clone Of: 1220329
Environment:
Last Closed: 2015-06-02 08:02:49 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Susant Kumar Palai 2015-05-14 08:28:59 UTC
+++ This bug was initially created as a clone of Bug #1220329 +++

Description of problem:
The rebalance logs contains messages like the following:

[2015-05-06 23:39:00.532273] I [dht-rebalance.c:1936:gf_defrag_get_entry] 0-patchy-dht: linkfile. Hence skip for file: /level05/level15/level25/level35/level45/level55/level65/level75/554aa5eb%%8LA99X6NJ6
[2015-05-06 23:39:00.532523] I [dht-rebalance.c:1936:gf_defrag_get_entry] 0-patchy-dht: linkfile. Hence skip for file: /level05/level15/level25/level35/level45/level55/level65/level75/554aa5eb%%GBWHI63XCE
[2015-05-06 23:39:00.532784] I [dht-rebalance.c:1936:gf_defrag_get_entry] 0-patchy-dht: linkfile. Hence skip for file: /level05/level15/level25/level35/level45/level55/level65/level75/554aa5eb%%1FGZKJ6C69
[2015-05-06 23:39:00.533025] I [dht-rebalance.c:1936:gf_defrag_get_entry] 0-patchy-dht: linkfile. Hence skip for file: /level05/level15/level25/level35/level45/level55/level65/level75/554aa5eb%%QBBFUHYYAB
[2015-05-06 23:39:00.533266] I [dht-rebalance.c:1936:gf_defrag_get_entry] 0-patchy-dht: linkfile. Hence skip for file: /level05/level15/level25/level35/level45/level55/level65/level75/554aa5eb%%PRCG2TLTCK
[2015-05-06 23:39:00.533506] I [dht-rebalance.c:1936:gf_defrag_get_entry] 0-patchy-dht: linkfile. Hence skip for file: /level05/level15/level25/level35/level45/level55/level65/level75/554aa5eb%%PM6V2AE0RB
[2015-05-06 23:39:00.533919] I [dht-rebalance.c:2267:gf_defrag_process_dir] 0-patchy-dht: Migration operation on dir /level05/level15/level25/level35/level45/level55/level65/level75 took 0.01 secs


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:

These files are linkfiles only on this particular local subvolume. As the log message does not indicate the subvol on which the linkfile was found, it looks like dht is skipping the file.

It would be better to :
1. Move the log level to DEBUG
2. Reword the message : Skipping linkfile: /level05/level15/level25/level35/level45/level55/level65/level75/554aa5eb%%PRCG2TLTCK

3. Include the subvol information if available

Additional info:

--- Additional comment from Anand Avati on 2015-05-12 12:28:02 MVT ---

REVIEW: http://review.gluster.org/10756 (dht/rebalance: Change log_level to DEBUG) posted (#1) for review on master by Susant Palai (spalai@redhat.com)

--- Additional comment from Anand Avati on 2015-05-12 18:45:32 MVT ---

COMMIT: http://review.gluster.org/10756 committed in master by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit ef37da74d4a8595cf53cf6dfe680fe080b7c8704
Author: Susant Palai <spalai@redhat.com>
Date:   Tue May 12 12:56:37 2015 +0530

    dht/rebalance: Change log_level to DEBUG
    
    Change-Id: I646367581d8ee8a9e5966ee302b19273a0c780ff
    BUG: 1220329
    Signed-off-by: Susant Palai <spalai@redhat.com>
    Reviewed-on: http://review.gluster.org/10756
    Reviewed-by: N Balachandran <nbalacha@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>

Comment 1 Anand Avati 2015-05-14 08:35:28 UTC
REVIEW: http://review.gluster.org/10778 (dht/rebalance: Change log_level to DEBUG) posted (#1) for review on release-3.7 by Susant Palai (spalai@redhat.com)

Comment 2 Anand Avati 2015-06-01 09:27:38 UTC
COMMIT: http://review.gluster.org/10778 committed in release-3.7 by Niels de Vos (ndevos@redhat.com) 
------
commit c762289c2c6ace36213feae80e9ccfe915aa87fd
Author: Susant Palai <spalai@redhat.com>
Date:   Tue May 12 12:56:37 2015 +0530

    dht/rebalance: Change log_level to DEBUG
    
    BUG: 1221503
    Change-Id: I4ac87bb69e05e2dd445fc0a5bcf48d5bd3d0020b
    Reviewed-on: http://review.gluster.org/10756
    Reviewed-by: N Balachandran <nbalacha@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>
    Signed-off-by: Susant Palai <spalai@redhat.com>
    Reviewed-on: http://review.gluster.org/10778

Comment 3 Niels de Vos 2015-06-02 08:02:49 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.1, please reopen this bug report.

glusterfs-3.7.1 has been announced on the Gluster Packaging mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.packaging/1
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.