Bug 122152 - Fam locking removable media, making it impossible to umount without killing fam
Fam locking removable media, making it impossible to umount without killing fam
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: fam (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-30 18:08 EDT by Kyrre Ness Sjøbæk
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-09 11:19:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kyrre Ness Sjøbæk 2004-04-30 18:08:41 EDT
Description of problem:
As with FC1, there is the problem with fam locking removable media
such as diskettes, making it impossible to umount it from inside GNOME
without killing off fam first (or logout/login).

Version-Release number of selected component (if applicable):
as supplied with FC2-t3 (fam-2.6.10-9)

How reproducible:



Steps to Reproduce:
1. Insert some media. Mount it using GNOMES built-in mounting support
(click on the my computer thingy and double click floppy).
2. Open some file on the floppy (guess this applies to all removable
media, but i have only tested a floppy).
3. Close down all visible programs accessing the floppy.
4. try to umount. get the "device is buisy" -error
5. Check with "lsof | grep floppy". see that fam holds it open.

Actual results:
Can't unmount floppy without logout/in or manually killing fam.

Expected results:
Fam gets the message to "pull out" or never ever touches removable
media...

Additional info:
Yes, its probably duplicated in the bugs for FC1...
Comment 1 Kyrre Ness Sjøbæk 2004-05-03 14:19:28 EDT
Just trying to push this one - it's that important. Because when a 
fresh (or an experienced) user installs Fedora Core 2, he/she is 95% 
for shure bound to try to use removable media. And he/she will find 
it easy (pretty much thanks to the new "my computer" interface) - 
untill he/she want his/her media back (we do not count those who just 
pull their diskettes/USB-keyrings straight out), and discovers that 
it isn't doable without a login/logout, he/she is going straight for 
a real breakdown in belief in Linux / fedora quality. And that is 
bad, because this distro is otherwise beginning to look real good. 
Comment 2 Richard Plana 2004-06-08 17:54:09 EDT
There was mention of a fix for this in fam-2.7.0. Bumping bug up
again. A lot of corporate users now user removable media, specially
graphics-oriented ones.
Comment 3 Kyrre Ness Sjøbæk 2004-06-09 11:19:34 EDT
Seems to be fixed in FC2 final. (an update that fixed it came within a
week after release). Got fixed in the last couple of days of fc2-t3 as
well.
Comment 4 Richard Plana 2004-06-09 12:00:53 EDT
Odd ... I was actually using FC2 final (updated to latest) when I
chimed in above. I mounted a Sony memory stick device (posing as a
virtual SCSI device) and couldn't umount it due to fam.

Should I open a new bug report for FC2?

Note You need to log in before you can comment on or make changes to this bug.