Bug 1221521 - Firefox doesn't work with Orca screen reader
Summary: Firefox doesn't work with Orca screen reader
Keywords:
Status: CLOSED DUPLICATE of bug 1067395
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: firefox
Version: 7.1
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Martin Stransky
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-14 09:31 UTC by Jiri Eischmann
Modified: 2021-09-03 09:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-21 10:06:59 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jiri Eischmann 2015-05-14 09:31:03 UTC
Description of problem:
Orca accessibility screen reader doesn't read anything in Firefox (and Thunderbird as well), thus it makes it impossible for visually impaired to use it.  

I also tested it on Fedora 22 where the new GTK3-based Firefox doesn't work with Orca reader either.

Comment 2 Martin Stransky 2015-05-18 18:07:30 UTC
Is that a dupe of https://bugzilla.redhat.com/show_bug.cgi?id=1067395 ? i.e. FF has to be restarted when accessibility is enabled.

Comment 3 Jiri Eischmann 2015-05-19 09:23:23 UTC
Seems so, when I restart Firefox, it indeed starts working with the reader.

Comment 4 Martin Stransky 2015-05-21 10:06:59 UTC

*** This bug has been marked as a duplicate of bug 1067395 ***

Comment 5 Andy 2021-09-03 09:20:11 UTC
As the bug that this one is supposed to duplicate has been supposedly fixed since 3.22 and FF 52, but the symptom of Orca not having access to Firefox and Thunderbird w/o restart remains in FF 92 and Orca 40.0, I guess this bug should be reopened?

Firefox has this tracked as well https://bugzilla.mozilla.org/show_bug.cgi?id=1601840

Also, see this discussion within the Orca team: https://gitlab.gnome.org/GNOME/orca/-/issues/212


Note You need to log in before you can comment on or make changes to this bug.