Bug 12216 - content dependency
content dependency
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: lpr (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-13 14:21 EDT by danel
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-13 14:21:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description danel 2000-06-13 14:21:00 EDT
The "lpr" system can't print past a page 
that starts as follows (content is between
the lines):
------------------------------------------------
  undef $iconfly;
  undef $flystring;
  undef @DAILY;
  undef @WEEKLY;
  undef @MONTHLY;
  undef @YEARLY;
  undef @dailydata;
  undef @weeklydata;
  undef @monthlydata;
  undef @yearlydata;

} #end sub CLEANUP
-------------------------------------------------
However, it prints ok when I change the content
like this (content is between lines):
-------------------------------------------------
  undef $iconfly;
  XXdef $flystring;
  XXdef @DAILY;
  undef @WEEKLY;
  undef @MONTHLY;
  undef @YEARLY;
  undef @dailydata;
  undef @weeklydata;
  undef @monthlydata;
  undef @yearlydata;

} #end sub CLEANUP

-------------------------------------------------
I've done lots of testing and it's very consistent.
My printer is an HP Laserjet 4000 with a parallel
cable.

My guess is that some script in the "lpr" system
is looking at the "undef" part of the content text
and (bizarely) interpreting that as a command 
(instead of as content.)  This is a very irritating
problem for a 'perl' programmer.  This occured on 
the nineth (9th) page of a 15 page file, so only the
first 8 pages printed.  I then sub-divided the 
remainder until I was down to just a 7 line file
that contained the cause of the problem.  Then I
started messing with the content, as shown above.

At the printer, the little LCD display indicates 
that data is arriving, and then the "Data" light
indicates there's data queued, but nothing prints.

Hope you can solve this, for the sake of us 'perl'
people.  

Alexander
Comment 1 Bernhard Rosenkraenzer 2000-06-16 06:31:28 EDT
I can't reproduce it with the version from 6.2 updates (you can install that on
6.1).
In Rawhide/7.0, we'll be using LPRng, which doesn't have the problem either (you
can download the source RPM from Rawhide and rebuild it; then it works on 6.1,
as well).

Note You need to log in before you can comment on or make changes to this bug.