Bug 122170 - gettext translations are not recoded from UTF-8 to local locale
gettext translations are not recoded from UTF-8 to local locale
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-01 05:52 EDT by Tomas Janousek
Modified: 2014-01-21 17:49 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-09 22:40:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Janousek 2004-05-01 05:52:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; cs-CZ; rv:1.6) Gecko/20040116

Description of problem:
yum with gettext translations assume I have UTF-8, and does not recode
to my locale.

In C++, I would do something like:
string localencoding = nl_langinfo(CODESET);
bind_textdomain_codeset("yum", localencoding.c_str());
(hope this helps as a hint for fixing yum, for fixing e2fsprogs it
simply must help because in C it's similar)

Note: I know that .fr packages are not yours, but this problem of
course appears when using some .mo files in UTF-8 with your yum.

Note 2: This problem applies also to your e2fsprogs, please fix.

Note 3: If you ask why do I have ISO-8859-2 instead of UTF-8, it's
because UTF isn't simply working with too many software I need to use.


Version-Release number of selected component (if applicable):
yum-2.0.6-1.20040416.1.fc1.fr

How reproducible:
Always

Steps to Reproduce:
1. Get cs.po from
http://linux.duke.edu/projects/yum/download/daily/2.0/yum-2.0.6-20040416.noarch.rpm
2. Set LANG=cs_CZ.ISO-8859-2
3. Run yum/fsck


Actual Results:  UTF-8 output on ISO-8859-2 console

Expected Results:  ISO-8859-2 output on ISO-8859-2 console

Additional info:
Comment 1 Jeff Johnson 2004-06-09 22:40:35 EDT
Hmmm, Red Hat is trying for UTF-8 everywhere. Recoding
UTF-8 to local encoding I'm gonna leave to the yum maintainer,
hence UPSTREAM.

Note You need to log in before you can comment on or make changes to this bug.