Bug 122172 - New user accounts cause KDE hang on login (related: kdeinit segfault on first ever boot?)
New user accounts cause KDE hang on login (related: kdeinit segfault on first...
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2004-05-01 08:10 EDT by Tim Jackson
Modified: 2015-01-04 17:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-12-08 01:20:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Complete system log of first system boot/login showing kswapd/kdeinit segfault (27.02 KB, text/plain)
2004-05-01 08:16 EDT, Tim Jackson
no flags Details

  None (edit)
Description Tim Jackson 2004-05-01 08:10:15 EDT
Description of problem:
On a completely fresh install of FC2 Test 3 on a Toshiba A40 laptop
(Celeron, 256MB), the first time that *any* user tries to log in to
KDE, something (kdeinit?) hangs forever.  This situation persists even
after gdm is restarted, until the whole system is rebooted. Then, the
user in question can log in OK, but other new users will experience
the same problem.

How reproducible:

The hang occurs when the login splash screen is showing the very last
icon highlighted ("Restoring Session"). At this point, the system is
still responsive; X is still up; the splash screen icon continues
flashing and the mouse pointer works. I can switch to a terminal and
kill gdm.

However, interestingly, if I kill gdm and then try to log in again as
the same user, the hang will occur again - but not necessarily at the
same point in the login process (at least according to the flashing
icons on the splash screen).  The point at which it occurs seems to
vary but in either case, the desktop never appears.

If the system is rebooted, the user can then (and subsequently) log in
without problems.

This happened with the first (non-root) user that I created in the
firstboot config, and exactly the same with a second subsequent user
that I created later the same day, but with a third user that I've
just tried creating (a couple of days later), everything worked OK. I
have not applied any updates to the system.

One thing which may or may not be related: on the *first ever boot*
(*only*) after install, it does appear that kswapd and (immediately
after) kdeinit segfaulted at the point of first ever login. I will
attach the logs of the first boot including the kernel dump of the
kdeinit crash.

To summarise:

1. Create new user 'foo'
2. Login from gdm as 'foo'
3. First time: hang occurs whilst splash screen is on the last icon
4. Subsequent logins: hang occurs at random point
5. Reboot
6. Login now OK, both during current session and after subsequent reboots

Possibly-related problem:

- First ever login: kdeinit/kswapd segfault
Comment 1 Tim Jackson 2004-05-01 08:16:55 EDT
Created attachment 99860 [details]
Complete system log of first system boot/login showing kswapd/kdeinit segfault

This log shows the complete first boot of the machine after installation. Key

15:08:30 - I (tim) log in for the first ever time. I've just created my local
user account in the first boot configurator.

15:08:48 - kswapd segfaults followed by kdeinit

15:11:13 - I give up waiting for KDE to start (at this stage, the splash screen
is showing but with "Restoring Session" endlessly flashing), and switch to a
terminal where I log in as root

15:14:04 - I do "killall gdm"

I must stress that although the "hang on login" problem occurred in exactly the
same way when I subsequently added another local user, the segfaults of
kswapd/kdeinit *have not occurred again*. The ONLY time they occurred is as
shown in this attachment.
Comment 2 Ngo Than 2004-06-24 19:03:39 EDT
it looks like a kernel bug here.
Comment 3 Tim Jackson 2004-06-25 03:49:51 EDT
It's probably worth noting that the same problem *did not* occur on a
fresh install of FC2 final on the same machine.
Comment 4 Dave Jones 2004-12-08 01:20:49 EST
reopen if it reoccurs.

Note You need to log in before you can comment on or make changes to this bug.