Bug 1222013 - Simplify creation and set-up of meta-volume (shared storage)
Summary: Simplify creation and set-up of meta-volume (shared storage)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: snapshot
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Avra Sengupta
QA Contact:
URL:
Whiteboard: Scheduler
Depends On:
Blocks: qe_tracker_everglades 1223201 1228181
TreeView+ depends on / blocked
 
Reported: 2015-05-15 13:31 UTC by Avra Sengupta
Modified: 2016-06-16 13:02 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1223201 1228181 (view as bug list)
Environment:
Last Closed: 2016-06-16 13:02:03 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Avra Sengupta 2015-05-15 13:31:48 UTC
Description of problem:
The creation and setting up (mounting on nodes) of meta-volume(gluster_shared_storage) should be made simpler for the admin.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anand Avati 2015-05-15 13:52:45 UTC
REVIEW: http://review.gluster.org/10793 (glusterd/shared_storage: Provide a volume set option to create and mount the shared storage) posted (#1) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 2 Anand Avati 2015-05-18 11:53:00 UTC
REVIEW: http://review.gluster.org/10793 (glusterd/shared_storage: Provide a volume set option to create and mount the shared storage) posted (#2) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 3 Anand Avati 2015-05-19 15:00:46 UTC
REVIEW: http://review.gluster.org/10793 (glusterd/shared_storage: Provide a volume set option to create and mount the shared storage) posted (#3) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 4 Anand Avati 2015-05-19 15:12:34 UTC
REVIEW: http://review.gluster.org/10793 (glusterd/shared_storage: Provide a volume set option to create and mount the shared storage) posted (#4) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 5 Anand Avati 2015-05-20 12:16:34 UTC
REVIEW: http://review.gluster.org/10793 (glusterd/shared_storage: Provide a volume set option to create and mount the shared storage) posted (#5) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 6 Anand Avati 2015-05-27 13:24:16 UTC
REVIEW: http://review.gluster.org/10793 (glusterd/shared_storage: Provide a volume set option to create and mount the shared storage) posted (#6) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 7 Anand Avati 2015-05-28 04:56:12 UTC
REVIEW: http://review.gluster.org/10793 (glusterd/shared_storage: Provide a volume set option to create and mount the shared storage) posted (#7) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 8 Anand Avati 2015-05-29 03:05:41 UTC
REVIEW: http://review.gluster.org/10793 (glusterd/shared_storage: Provide a volume set option to create and mount the shared storage) posted (#8) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 9 Anand Avati 2015-05-29 11:24:37 UTC
REVIEW: http://review.gluster.org/10793 (glusterd/shared_storage: Provide a volume set option to create and mount the shared storage) posted (#9) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 10 Anand Avati 2015-05-30 10:47:36 UTC
REVIEW: http://review.gluster.org/10793 (glusterd/shared_storage: Provide a volume set option to create and mount the shared storage) posted (#10) for review on master by Niels de Vos (ndevos@redhat.com)

Comment 11 Anand Avati 2015-06-01 06:43:25 UTC
REVIEW: http://review.gluster.org/10793 (glusterd/shared_storage: Provide a volume set option to create and mount the shared storage) posted (#11) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 12 Anand Avati 2015-06-01 08:57:09 UTC
REVIEW: http://review.gluster.org/10793 (glusterd/shared_storage: Provide a volume set option to create and mount the shared storage) posted (#12) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 13 Anand Avati 2015-06-02 06:56:59 UTC
REVIEW: http://review.gluster.org/10793 (glusterd/shared_storage: Provide a volume set option to create and mount the shared storage) posted (#13) for review on master by Avra Sengupta (asengupt@redhat.com)

Comment 14 Avra Sengupta 2015-06-04 11:17:51 UTC
Fixed with http://review.gluster.org/#/c/10793/

Comment 15 Nagaprasad Sathyanarayana 2015-10-25 15:03:26 UTC
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.

Comment 16 Niels de Vos 2016-06-16 13:02:03 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.