Bug 122203 - i2o Device Nodes not created/recognized when i2o_block is used
Summary: i2o Device Nodes not created/recognized when i2o_block is used
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kudzu   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-01 21:08 UTC by Stuart Cianos
Modified: 2014-03-17 02:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-20 09:18:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kudzu-i2o.patch (1.78 KB, patch)
2004-05-07 02:05 UTC, Warren Togami
no flags Details | Diff

Description Stuart Cianos 2004-05-01 21:08:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b)
Gecko/20040421

Description of problem:
When installing Test3, the i2o device nodes are not created or
recognized by Anaconda, resulting in "No Hard Drives Found".

However, the i2o subsystem _is_ functional. For example, if I create
the device nodes in /tmp:

mknod /tmp/i2o/hda b 80 0
mknod /tmp/i2o/hda1 b 80 1
mknod /tmp/i2o/hda2 b 80 2
.....
mknod /tmp/i2o/hda8 b 80 8

I am able to mount my partitions with no problems. Hence, it appears
that the i2o block drivers are fully functional, however Anaconda is
not creating the correct device entries or is not recognizing the i2o
device entries.

To be sure, I also tried manual hardware configuration (noprobe) to
ensure that it wasn't a conflict involving Anaconda seeing my other
SCSI controllers. Sure enough, same problem even when the other SCSI
drivers are not loaded.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot Test3 Installer CD
2. Select standard install
3. Hard drives will not be found
    

Additional info:

i2o drivers seem to be working great... The i2o_block drivers
definately seem to have some performance improvements over dpt_i2o.
Unfortunately, Anaconda won't isntall to them yet!

Comment 1 Jeremy Katz 2004-05-03 17:54:30 UTC
This is because kudzu can't probe i2o disks.

Comment 2 Warren Togami 2004-05-07 02:05:54 UTC
Created attachment 100058 [details]
kudzu-i2o.patch

Markus Lidel wrote this patch.	I am testing it now.


Note You need to log in before you can comment on or make changes to this bug.