Bug 1222068 - undercloud install failure - File "/tmp/tmpwNKxjS/install.d/02-puppet-stack-config", No such file or directory
Summary: undercloud install failure - File "/tmp/tmpwNKxjS/install.d/02-puppet-stack-c...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: Director
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ga
: Director
Assignee: James Slagle
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-15 16:46 UTC by wes hayutin
Modified: 2015-08-05 13:51 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:51:28 UTC
Target Upstream Version:


Attachments (Terms of Use)
instack undercloud install failure output (16.71 KB, text/plain)
2015-05-15 16:46 UTC, wes hayutin
no flags Details
list of rpms on the baremetal box (22.01 KB, text/plain)
2015-05-15 19:49 UTC, wes hayutin
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description wes hayutin 2015-05-15 16:46:11 UTC
Created attachment 1025947 [details]
instack undercloud install failure output

Description of problem:

00:22:08.901 Traceback (most recent call last):
00:22:08.901   File "/tmp/tmpwNKxjS/install.d/02-puppet-stack-config", line 30, in <module>
00:22:08.902     subprocess.check_call(['generate-keystone-pki', '-d', keystone_pki_dir])
00:22:08.902   File "/usr/lib64/python2.7/subprocess.py", line 537, in check_call
00:22:08.903     retcode = call(*popenargs, **kwargs)
00:22:08.903   File "/usr/lib64/python2.7/subprocess.py", line 524, in call
00:22:08.903     return Popen(*popenargs, **kwargs).wait()
00:22:08.904   File "/usr/lib64/python2.7/subprocess.py", line 711, in __init__
00:22:08.904     errread, errwrite)
00:22:08.904   File "/usr/lib64/python2.7/subprocess.py", line 1308, in _execute_child
00:22:08.905     raise child_exception
00:22:08.905 OSError: [Errno 2] No such file or directory
00:22:08.905 INFO: 2015-05-15 16:09:51,205 -- ############### End stdout/stderr logging ###############
00:22:08.905 ERROR: 2015-05-15 16:09:51,206 --     Hook FAILED.
00:22:08.906 ERROR: 2015-05-15 16:09:51,206 -- Failed running command ['dib-run-parts', u'/tmp/tmpwNKxjS/install.d']
00:22:08.906   File "/usr/lib/python2.7/site-packages/instack/main.py", line 163, in main
00:22:08.907     em.run()
00:22:08.907   File "/usr/lib/python2.7/site-packages/instack/runner.py", line 79, in run
00:22:08.907     self.run_hook(hook)
00:22:08.907   File "/usr/lib/python2.7/site-packages/instack/runner.py", line 174, in run_hook
00:22:08.908     raise Exception("Failed running command %s" % command)
00:22:08.908 ERROR: 2015-05-15 16:09:51,206 -- None

Comment 1 wes hayutin 2015-05-15 16:49:28 UTC
Build mark: poodle=2015-05-13.2

Comment 2 James Slagle 2015-05-15 19:14:07 UTC
generate-keystone-pki is provided by os-cloud-config. If that's missing, then either os-cloud-config is not installed, or a really old version is installed. It usually gets installed during 01-package-installs, but it looks like that didn't run. That could be caused by an old diskimage-builder.

What is the output of:

yum list --show-duplicates os-cloud-config diskimage-builder

This looks like a problem with the poodle to be honest.

Comment 3 wes hayutin 2015-05-15 19:49:45 UTC
Created attachment 1026040 [details]
list of rpms on the baremetal box

The build mark of the poodle will indicate which poodle is in use.
I see there is still a problem w/ collecting logs, sigh..

The rpm content is from:
rhos 7-director poodle 2015-05-13.2

I'll get a link

Comment 4 wes hayutin 2015-05-15 19:59:06 UTC
rerunning that build mark is off or the poodle was removed

Comment 5 James Slagle 2015-05-15 20:20:30 UTC
i see the issue is in the diskimage-builder rpm from that poodle where 01-package-installs was not set +x.

should be fixed by:
http://pkgs.devel.redhat.com/cgit/rpms/diskimage-builder/commit/?h=rhos-7.0-rhel-7&id=86b831fe19b09323d20d697142e7848aabd3f9de

brew build:
https://brewweb.devel.redhat.com/taskinfo?taskID=9174895

Comment 7 Dan Macpherson 2015-05-20 06:15:03 UTC
I experienced the same thing at several points for this package and several others. Was missing the following packages:

os-cloud-config
os-apply-config
os-refresh-config
ipxe-bootimgs
os-net-config
openstack-tuskar

Comment 8 James Slagle 2015-05-20 14:35:28 UTC
(In reply to Dan Macpherson from comment #7)
> I experienced the same thing at several points for this package and several
> others. Was missing the following packages:
> 
> os-cloud-config
> os-apply-config
> os-refresh-config
> ipxe-bootimgs
> os-net-config
> openstack-tuskar

what version of diskimage-builder do you have? and what rhel-ops7 poodle/puddle is enabled?

Comment 12 Omri Hochman 2015-07-09 20:06:00 UTC
unable to reproduce : 
instack-0.0.7-1.el7ost.noarch
instack-undercloud-2.1.2-11.el7ost.noarch

Comment 14 errata-xmlrpc 2015-08-05 13:51:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.