Bug 122212 - Config file setup has few wrong options to initially start
Summary: Config file setup has few wrong options to initially start
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dovecot
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John Dennis
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC2Blocker
TreeView+ depends on / blocked
 
Reported: 2004-05-01 22:59 UTC by Mike Chambers
Modified: 2014-01-21 22:49 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2004-05-19 10:27:17 UTC


Attachments (Terms of Use)
Config file (17.65 KB, text/plain)
2004-05-01 23:00 UTC, Mike Chambers
no flags Details

Description Mike Chambers 2004-05-01 22:59:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040422

Description of problem:
On a fresh install of dovecot, the /etc/dovecot.conf file is setup it
seems for only imap intially, and should be setup for pop3 as well.

Also the auth lines toward the bottom seem to point to a location/file
that don't exist, mainly auth_userdb and auth_passdb

And because of above, dovecot won't start.

Version-Release number of selected component (if applicable):
dovecot-0.99.10.4-3

How reproducible:
Always

Steps to Reproduce:
1.Install dovecot
2.service dovecot start
3.
    

Actual Results:  service dovecot start show the OK but doesn't start
up any daemons.

Expected Results:  service dovecot start should start up the daemon
and allow imap and pop3 initially to run unless the user doesn't want
one or the other.

Additional info:

The main 3 lines at least that I see that need auth_userdb = pgsql
/usr/local/etc/dovecot-pgsql.conffixed are below..

#protocols = imap imaps
should be protocols = imap imaps pop3 pop3s

auth_userdb = pgsql /usr/local/etc/dovecot-pgsql.conf
should be below..
auth_userdb = passwd

auth_passdb = pgsql /usr/local/etc/dovecot-pgsql.conf
should be below...
auth_passdb = shadow


I've also attached my dovecot.conf file if you want to compare.

Comment 1 Mike Chambers 2004-05-01 23:00:56 UTC
Created attachment 99868 [details]
Config file

Comment 2 Warren Togami 2004-05-07 14:46:39 UTC
I have set auth_userdb = passwd and auth_passdb = pam.  I will not set
default protocols because by default it works with imap and imaps, and
the administrator has the option of changing this.

Comment 3 Warren Togami 2004-05-07 16:24:26 UTC
The package update was past the freeze deadline, so it has been
rejected.  It will go out as a FC2 update later.


Note You need to log in before you can comment on or make changes to this bug.