Bug 122218 - OLYMPUS entry needed in updfstab.conf.default
OLYMPUS entry needed in updfstab.conf.default
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-01 21:32 EDT by Per Bjornsson
Modified: 2014-03-16 22:44 EDT (History)
2 users (show)

See Also:
Fixed In Version: FC3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-19 02:36:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Per Bjornsson 2004-05-01 21:32:28 EDT
Description of problem:
Olympus digital cameras are often (always?) USB mass storage devices,
and need an entry in updfstab.conf.default in order to be correctly
autodetected. The olympus camera I have access to is an Olympus Stylus
400 Digital; partition 1 is mountable so it's fine just to add OLYMPUS
to the 'camera' section in updfstab.conf.default .

--
[perbj@minicooper perbj]$ cat /proc/scsi/scsi
Attached devices:
Host: scsi3 Channel: 00 Id: 00 Lun: 00
  Vendor: OLYMPUS  Model: u20D,S400D,u400D Rev: 1001
  Type:   Direct-Access                    ANSI SCSI revision: 02
--

As a local fix, I added this to /etc/updfstab.conf:
device camera {
    partition 1
    match   hd OLYMPUS
}

and now the camera hotplugs perfectly and shows up in Nautilus.


Version-Release number of selected component (if applicable):
kudzu-1.1.57-1

How reproducible:
Always

Steps to Reproduce:
1.Plug in an Olympus digital camera
2.Look for it in the Nautilus "Computer" window
3.Be surprised that it isn't there
Comment 1 Gustavo Maciel Dias Vieira 2004-06-16 20:42:50 EDT
"match hd OLYMPUS" works also for my D-510Z.

I've noticed that the match happens against the short SCSI descripiton
("Olympus D-510ZOOM"). The USB description is a bit more, err,
descriptive ("Olympus Optical Co., Ltd Camedia C-700/C-3040/C-4000
Zoom Camera").

If the USB description was used, it would match the existing "CAMERA"
entry. Of course, I have no idea what I'm talking about, but the more
verbose USB description might reduce the number of entries.
Comment 2 Bill Nottingham 2004-06-28 17:11:17 EDT
The USB description isn't actually attached to the *device* node,
which is what is interesting for updfstab's case, though.
Comment 3 Per Bjornsson 2004-11-19 02:36:36 EST
Sorry I didn't see that there were more comments on this bug earlier,
and I don't actually understand what was missing since my entry made
it work... In any case, this is all moot now as the bug is fixed by
fiat, or perhaps rather by the replacement of updfstab by HAL/g-v-m,
which detect and mount the camera correctly.

Note You need to log in before you can comment on or make changes to this bug.