Bug 122220 - Problems with ethernet card (3c59x)
Problems with ethernet card (3c59x)
Status: CLOSED DUPLICATE of bug 107389
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2004-05-01 21:42 EDT by Johnny Mnemonic
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:02:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Johnny Mnemonic 2004-05-01 21:42:09 EDT
Description of problem:
eth0 seems to have serious problems communicating with external world.
tcpdump shows outgoing packets but nothing coming back, and my hub's
leds don't indicate any data around, so packets never phisically leave
my network card.

Version-Release number of selected component (if applicable):

How reproducible:
I've just tried one installation (custom), with common packets
selected. I've been redhat user since version 5, so my installation
procedure is roughly the same as always.

Steps to Reproduce:
1. Install Fedora Core 2
2. Configure ethernet as DHCP (shouldn't matter)
3. Watch your NIC not to work.
Additional info:
Actually after messing for a few minutes with ifconfig up/down,
tcpdump, ping, and so on, i started getting the following kernel
message every 5-10 seconds (i didn't measure it):

eth0: Transmit error, Tx status register 90.
  Flags; bus-master 1, dirty 1(1) current 17(1)
  Transmit list 1785a340 vs. 1985a2a0.
  0: @1985a200  length 8000002a status 8000002a
  1: @1985a2a0  length 8000004e status 0000004e
  2: @1985a340  length 80000046 status 00000046
  3: @1985a3e0  length 80000156 status 00000156
  4: @1985a480  length 80000046 status 00000046
  5: @1985a520  length 80000046 status 00000046
  6: @1985a5c0  length 80000156 status 00000156
  7: @1985a660  length 80000156 status 00000156
  8: @1985a700  length 80000156 status 00000156
  9: @1985a7a0  length 80000156 status 00000156
  10: @1985a840  length 80000156 status 00000156
  11: @1985a8e0  length 80000156 status 00000156
  12: @1985a980  length 80000156 status 00000156
  13: @1985aa20  length 8000002a status 0000002a
  14: @1985aac0  length 8000002a status 0000002a
  15: @1985ab60  length 8000002a status 8000002a
Comment 1 Johnny Mnemonic 2004-05-01 21:44:56 EDT
I'd like to attach "lspci -v" output but you ran out of disk
space..how incredible.

This should be the relevant part anyway:
02:0b.0 Ethernet controller: 3Com Corporation 3c905 100BaseTX [Boomerang]
        Flags: bus master, medium devsel, latency 32, IRQ 9
        I/O ports at d400
Comment 2 Doncho N. Gunchev 2004-05-04 04:59:05 EDT
maybe this is related to bugs #107389 (I described my problem there)
and #116095. I have (lspci -v):

00:0f.0 Ethernet controller: 3Com Corporation 3c590 10BaseT [Vortex]
        Flags: bus master, medium devsel, latency 248, IRQ 12
        I/O ports at d000 [size=32]
        Expansion ROM at cffe0000 [disabled] [size=64K]

Comment 3 Alan Cox 2004-05-22 12:34:28 EDT

*** This bug has been marked as a duplicate of 107389 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:02:56 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.