Bug 1222262 - liveinst in f22-kde-live-TC4 fails to start
Summary: liveinst in f22-kde-live-TC4 fails to start
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: David Shea
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker https://fedoraproject...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-17 02:42 UTC by satellitgo
Modified: 2015-09-16 16:06 UTC (History)
13 users (show)

Fixed In Version: anaconda-23.18-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-09-16 16:06:51 UTC


Attachments (Terms of Use)

Description satellitgo 2015-05-17 02:42:09 UTC
Description of problem:
liveinst in f22-kde-live-TC4 fails to start

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
[liveuser@localhost ~]$ su
[root@localhost liveuser]# liveinst
Starting installer, one moment...
anaconda 22.20.12-1 for Fedora 22 (pre-release) started.
 * installation log files are stored in /tmp during the installation
 * shell is available on TTY2 and in second TMUX pane (ctrl+b, then press 2)
 * if the graphical installation interface fails to start, try again with the
   inst.text bootoption to start text installation
 * when reporting a bug add logs from /tmp as separate text/plain attachments
Traceback (most recent call last):
  File "/sbin/anaconda", line 1254, in <module>
    env_langs = localization.get_language_locales(os.environ["LANG"])
  File "/usr/lib64/python2.7/site-packages/pyanaconda/localization.py", line 300, in get_language_locales
    if "language" not in parts:
TypeError: argument of type 'NoneType' is not iterable
[root@localhost liveuser]# 


Expected results:start anaconda 22.20.12-1 installer


Additional info:

Comment 1 Dan Mossor [danofsatx] 2015-05-17 02:56:50 UTC
Confirmed on F22 Plasma x86-64. When running liveinst with no options on the command line, the errors noted are produced. When specifying 'liveinst --lang US' on the command line, or specifying a kickstart file to be used, it proceeds normally.

Also noted, but unsure if this is normal, the environment variable LANGUAGE is blank within the live environment.

Comment 2 Fedora Blocker Bugs Application 2015-05-17 14:28:16 UTC
Proposed as a Blocker for 22-final by Fedora user rdieter using the blocker tracking app because:

 installer fails to run on kde spin

Comment 3 Jaroslav Reznik 2015-05-18 13:32:06 UTC
It's happening on command line only and it's easy to workaround if common bug.

It runs when started from the Kicker menu (GUI) - that's something I expect 99% users do (although it's less discoverable as it's not on desktop now but FE is accepted). So I tend to -1 blocker/+1 FE.

Comment 4 Stephen Gallagher 2015-05-18 14:07:46 UTC
If it works from the GUI launcher, then I'm -1 blocker. It looks like there's a difference in the environments for launching it from the terminal as opposed to the GUI. I suspect that the LANG variable is set differently.

I'm -1 blocker/+1 FE on this as well.

Comment 5 David Shea 2015-05-18 14:08:15 UTC
It looks like KDE has known about the empty $LANGUAGE thing for a while (https://bugs.kde.org/show_bug.cgi?id=198260) and a pedantic reading of the gettext man page says that this is ok. This is so dumb.

Comment 6 satellitgo 2015-05-18 14:17:12 UTC
"unset LANGUAGE" run before liveinst may work also.  davidshea on #anaconda

Comment 7 Petr Schindler 2015-05-18 16:17:37 UTC
Discussed at today's blocker review meeting [1]. 

This bug was rejected as blocker but accepted as Freeze Exception: This breakage isn't considered blocking since the GUI works for installation. A fix would be considered during freeze.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2015-05-18

Comment 8 Adam Williamson 2015-06-10 22:25:09 UTC
Clearing F22 accepted / nominated freeze exception status as F22 has shipped, per https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Trackers . You may nominate as an Alpha, Beta or Final freeze exception for F23 if desired using the web application - https://qa.fedoraproject.org/blockerbugs/propose_bug (though it is not currently set up for F23) - or by marking the bug as blocking AlphaFreezeException, BetaFreezeException, or FinalFreezeException.


Note You need to log in before you can comment on or make changes to this bug.