Bug 1222273 - KDE Plasma desktop hanging on lock screen
Summary: KDE Plasma desktop hanging on lock screen
Keywords:
Status: CLOSED DUPLICATE of bug 1188772
Alias: None
Product: Fedora
Classification: Fedora
Component: plasma-desktop
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: KDE SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-17 05:00 UTC by Nick Coghlan
Modified: 2015-05-26 12:21 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-18 10:39:24 UTC
Type: Bug


Attachments (Terms of Use)

Description Nick Coghlan 2015-05-17 05:00:44 UTC
Description of problem:

In F22 beta, I've had the KDE lock screen lock up entirely 3 times now, and had to reboot the computer to regain access. (Ctrl-Alt-Backspace had no effect, and I believe I also tried switching to a virtual console with no luck either)

Version-Release number of selected component (if applicable):

plasma-desktop-5.3.0-5.fc22.x86_64
xorg-x11-server-Xorg-1.17.1-11.fc22.x86_64
xorg-x11-drv-libinput-0.9.0-1.fc22.x86_64
libinput-0.15.0-1.fc22.x86_64

(I'm not sure what they actual culprit is, but these seem potentially relevant)

How reproducible:

Seems to happen fairly consistently if I leave the computer locked for several hours.

Steps to Reproduce:
1. Ctrl-Alt-L to lock the screen
2. Wait several hours (e.g. overnight)
3.

Actual results:

The system becomes completely non-responsive to user input (no mouse, no keyboard).

For the most recent lockup, the lock screen was still displaying 4:11 am when I went to unlock the machine around 1:30 pm.

Looking at journalctl, I can see that the chatter from cron (for dnf invocation) keeps going past that point, but the last message from gdm-x-session is "May 17 04:11:36 thechalk /usr/libexec/gdm-x-session[1840]: powerdevil: Kbd backlight brightness value:  0"

(That particular message appears to be innocuous, but the timestamp is notable, as it's the last message from gdm-x-session until the reboot this afternoon)

Expected results:

Screen is responsive, allowing me to unlock it and use the machine.

Additional info:

I'm running the F22 beta, having installed from the Fedora Workstation live USB image and then switched the desktop to KDE rather than Gnome.

Hardware is a HP Spectre 360.

The following segfaults reported by journalctl may be potentially relevant (although none of them appear to correspond with the most recent screen lockup):

$ journalctl | grep segfault
Apr 25 07:59:14 thechalk kernel: polkitd[1098]: segfault at 15 ip 00007f559decbe10 sp 00007ffc563efcc0 error 4 in libmozjs-17.0.so[7f559ddd0000+3ba000]
Apr 26 13:44:37 thechalk kernel: QXcbEventReader[8593]: segfault at 7f636f6ad699 ip 00007f636f6ad699 sp 00007f636cac2da0 error 14 in locale-archive[7f636f93a000+66ba000]
May 06 05:31:57 thechalk kernel: kactivitymanage[1940]: segfault at 7f81d992bcf0 ip 00007f81d9b71661 sp 00007ffc6bf478e8 error 4 in libQt5Sql.so.5.4.1[7f81d9b5d000+3f000]
May 06 05:31:57 thechalk kernel: kscreen_backend[1937]: segfault at 7f3489b59718 ip 00007f3498919582 sp 00007ffdbde99a48 error 4 in libQt5Gui.so.5.4.1[7f349883c000+50a000]
May 07 17:58:47 thechalk kernel: kactivitymanage[2275]: segfault at 7f98f65eccf0 ip 00007f98fc36f661 sp 00007ffd86b155c8 error 4 in libQt5Sql.so.5.4.1[7f98fc35b000+3f000]
May 07 23:54:44 thechalk kernel: kactivitymanage[2560]: segfault at 7fbd102c8cf0 ip 00007fbd1050e661 sp 00007fff839dae68 error 4 in libQt5Sql.so.5.4.1[7fbd104fa000+3f000]
May 10 15:43:18 thechalk kernel: kactivitymanage[2938]: segfault at 7f4289d42cf0 ip 00007f4289f88661 sp 00007ffc62ef3b38 error 4 in libQt5Sql.so.5.4.1[7f4289f74000+3f000]
May 13 02:21:39 thechalk kernel: kactivitymanage[2311]: segfault at 7ff95395fcf0 ip 00007ff953ba5661 sp 00007ffc4c8ef798 error 4 in libQt5Sql.so.5.4.1[7ff953b91000+3f000]
May 16 17:57:39 thechalk kernel: tracker-miner-a[2358]: segfault at 0 ip 00007f4250a84724 sp 00007ffdd6831db0 error 4 in libgio-2.0.so.0.4400.0[7f4250a2e000+176000]

Comment 1 Rex Dieter 2015-05-17 13:11:12 UTC
Can you get any backtraces for these crashes?  (drkonqi or abrt)?

It's very likely to be video driver related, but that's just speculation without backtrace details.

Comment 2 Nadim Kobeissi 2015-05-17 14:34:50 UTC
I believe this is a duplicate of bug 1221050.

Comment 3 Rex Dieter 2015-05-17 18:17:05 UTC
How so?  the linked bug is about suspend/resume, not lock screen.

Comment 4 Nadim Kobeissi 2015-05-17 18:22:24 UTC
The underlying cause is the same, I believe. Note that OP is not referring to the lock screen here, but to the lock screen specifically after a few hours of idelenss. Try downgrading the kernel to 3.19 as mentioned in bug 1221050; it might prove to be a workaround for this issue as well.

Comment 5 Nick Coghlan 2015-05-18 07:04:04 UTC
I think the kactivitymanager crashes may have generated notifications after the reboot - is there someone I can look to see if the stack traces are still available?

ABRT didn't seem to trigger at all for any of them, but I'll look there as well.

As far as bug 1221050 goes, it's plausible they'll turn out to have a common driver related cause, but I wouldn't be prepared to call them duplicates yet. However, I'll check to see if I can reproduce bug 1221050 using suspend/resume explicitly (I tend not to rely on suspend/resume normally)

Comment 6 Nick Coghlan 2015-05-18 10:39:24 UTC
I can reproduce bug 1221050, and it looks like abrt already reported most of the various segfaults I saw in the logs (details below). Since I don't think there's anything particularly useful that can be investigated further here, and there are known issues with kernel compatibility on the Spectre 360's Broadwell chipset, I think duping this onto the pm-suspend/hibernate bug is a reasonable way to go.

$ abrt-cli ls
id a82b46675f72cb6e34dc994e7fe0b472096ea691
reason:         tracker-miner-apps killed by SIGSEGV
time:           Sat 16 May 2015 17:57:39 AEST
cmdline:        /usr/libexec/tracker-miner-apps
package:        tracker-1.4.0-1.fc22
uid:            1000 (ncoghlan)
count:          1
Directory:      /var/tmp/abrt/ccpp-2015-05-16-17:57:39-2358

id 5738ab6cb90c0f0d31844f903a1ca8d2a3477805
reason:         kded5 killed by SIGSEGV
time:           Sat 09 May 2015 14:31:44 AEST
cmdline:        /usr/bin/kded5
package:        kf5-kded-5.9.0-1.fc22
uid:            1000 (ncoghlan)
count:          2
Directory:      /var/tmp/abrt/ccpp-2015-05-09-14:31:44-2912
Reported:       https://retrace.fedoraproject.org/faf/reports/bthash/39b0ae52bde5567a43151468934723b5cc5b76c3

id 1d8e7ca89055a21b717b60a7242d87bc51e321ac
reason:         kscreenlocker_greet killed by SIGABRT
time:           Mon 04 May 2015 00:10:05 AEST
cmdline:        /usr/libexec/kscreenlocker_greet --graceTime 4744 --ksldfd 32
package:        plasma-workspace-5.3.0-1.fc22
uid:            1000 (ncoghlan)
count:          1
Directory:      /var/tmp/abrt/ccpp-2015-05-04-00:10:05-32765
Reported:       https://retrace.fedoraproject.org/faf/reports/bthash/515e4fdb79c4df8d8322c1906f08d1e4d8605b9c

id b88f287f9b84160a92f069195d5e41e2a292e60d
reason:         WARNING: CPU: 0 PID: 1748 at drivers/gpu/drm/i915/intel_display.c:1260 assert_plane.constprop.80+0x74/0xb0 [i915]() [i915]
time:           Thu 23 Apr 2015 20:43:05 AEST
cmdline:        BOOT_IMAGE=/vmlinuz-4.0.0-0.rc5.git4.1.fc22.x86_64 root=/dev/mapper/fedora_thechalk-root ro rd.luks.uuid=luks-827c1b02-e4e8-4246-b939-d392850c1762 rd.lvm.lv=fedora_thechalk/swap rd.lvm.lv=fedora_thechalk/root rhgb quiet LANG=en_AU.UTF-8
package:        kernel
count:          3
Directory:      /var/tmp/abrt/oops-2015-04-23-20:43:05-973-0
Reported:       https://retrace.fedoraproject.org/faf/reports/bthash/94fac73ca67d8508dbbde162d09911a06aa092dc
                https://retrace.fedoraproject.org/faf/reports/615489/
                https://bugzilla.redhat.com/show_bug.cgi?id=1207233

id c0993852ee6e320144f2484d4f447b928c1ad3b6
reason:         kactivitymanagerd killed by SIGSEGV
time:           Sun 26 Apr 2015 13:44:37 AEST
cmdline:        /usr/bin/kactivitymanagerd -session 10dcc9d1ce000142998930600000021390006_1430019839_4450
package:        kf5-kactivities-5.9.0-1.fc22
uid:            1000 (ncoghlan)
count:          1
Directory:      /var/tmp/abrt/ccpp-2015-04-26-13:44:37-8576
Reported:       https://retrace.fedoraproject.org/faf/reports/bthash/e36b61f1c7fafaa8e57a47ea08d5ae31f424c98e
                https://retrace.fedoraproject.org/faf/reports/458854/
                https://bugzilla.redhat.com/show_bug.cgi?id=1210559

*** This bug has been marked as a duplicate of bug 1221050 ***

Comment 7 Nick Coghlan 2015-05-26 12:21:35 UTC
The Intel i915 graphics driver issues described in bug 1188772 seem like a more plausible culprit here.

*** This bug has been marked as a duplicate of bug 1188772 ***


Note You need to log in before you can comment on or make changes to this bug.