Bug 1222318 - (os-refresh-config) [ERROR] during configure phase. [Command '['dib-run-parts', '/usr/libexec/os-refresh
Summary: (os-refresh-config) [ERROR] during configure phase. [Command '['dib-run-parts...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: Director
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ga
: 7.0 (Kilo)
Assignee: Jay Dobies
QA Contact: yeylon@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-17 15:28 UTC by wes hayutin
Modified: 2016-04-18 07:12 UTC (History)
13 users (show)

Fixed In Version: openstack-tuskar-0.4.16-2.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-01-11 13:51:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description wes hayutin 2015-05-17 15:28:51 UTC
Description of problem:

17:54:06 + semanage port -a -t http_port_t -p tcp 8088
17:54:06 dib-run-parts Sat May 16 21:54:03 UTC 2015 88-httpd-vhost-port completed
17:54:06 dib-run-parts Sat May 16 21:54:03 UTC 2015 Running /usr/libexec/os-refresh-config/configure.d/90-tuskar-db-sync
17:54:06 + TUSKAR_CONF=/etc/tuskar/tuskar.conf
17:54:06 + TUSKAR_ROLE_DIRECTORY=
17:54:06 + '[' -z '' ']'
17:54:06 + '[' -d /usr/share/openstack-tripleo-heat-templates/ ']'
17:54:06 + TUSKAR_ROLE_DIRECTORY=/usr/share/openstack-tripleo-heat-templates/
17:54:06 + os-is-bootstrap-host
17:54:06 [2015/05/16 09:54:03 PM] [WARNING] DEPRECATED: falling back to /var/run/os-collect-config/os_config_files.json
17:54:06 [2015/05/16 09:54:03 PM] [WARNING] DEPRECATED: falling back to /var/run/os-collect-config/os_config_files.json
17:54:06 + sudo -u tuskar -- tuskar-dbsync --config-file /etc/tuskar/tuskar.conf
17:54:06 2015-05-16 21:54:04.271 1718 CRITICAL tuskar [-] InvalidRepositoryError: /usr/lib/python2.7/site-packages/tuskar/db/sqlalchemy/migrate_repo
17:54:06 
17:54:06 [2015-05-16 21:54:04,316] (os-refresh-config) [ERROR] during configure phase. [Command '['dib-run-parts', '/usr/libexec/os-refresh-config/configure.d']' returned non-zero exit status 1]
17:54:06 
17:54:06 [2015-05-16 21:54:04,316] (os-refresh-config) [ERROR] Aborting...
17:54:06 
17:54:06 stderr:
17:54:06 ERROR: openstack Command 'instack-install-undercloud' returned non-zero exit status 1

Comment 7 Dan Macpherson 2015-05-20 06:15:09 UTC
I experienced the same thing at several points for this package and several others. Was missing the following packages:

os-cloud-config
os-apply-config
os-refresh-config
ipxe-bootimgs
os-net-config
openstack-tuskar

Comment 10 James Slagle 2015-05-20 17:45:35 UTC
looks like /usr/lib/python2.7/site-packages/tuskar/db/sqlalchemy/migrate_repo/migrate.cfg is missing as expected by sqlalchemy migrate. could be a packaging issue

Comment 11 Mike Burns 2015-05-20 19:12:26 UTC
I did a quick check on both osp and rdo packages.  The file isn't there on rdo either.  It's in the source tarball, but not installed.

Comment 16 Alexander Chuzhoy 2015-06-01 21:07:36 UTC
Verified:
Environment: 
instack-0.0.6-5.el7ost.noarch
instack-undercloud-2.1.0-3.el7ost.noarch


The command now is "openstack undercloud install" and the reported issue doesn't reproduce.

Comment 17 Ramon Acedo 2015-06-05 15:27:41 UTC
I'm still hitting this issue today with these versions:
instack-0.0.7-1.el7ost.noarch
python-rdomanager-oscplugin-0.0.6-1.el7ost.noarch

[...]
Notice: Finished catalog run in 484.35 seconds
+ rc=6
+ set -e
+ echo 'puppet apply exited with exit code 6'
puppet apply exited with exit code 6
+ '[' 6 '!=' 2 -a 6 '!=' 0 ']'
+ exit 6
[2015-06-05 10:59:40,569] (os-refresh-config) [ERROR] during configure phase. [Command '['dib-run-parts', '/usr/libexec/os-refresh-config/configure.d']' returned non-zero exit status 6]

[2015-06-05 10:59:40,569] (os-refresh-config) [ERROR] Aborting...
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 515, in install
    _run_orc(instack_env)
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 452, in _run_orc
    _run_live_command(args, instack_env, 'os-refresh-config')
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 288, in _run_live_command
    raise RuntimeError('%s failed. See log for details.', name)
RuntimeError: ('%s failed. See log for details.', 'os-refresh-config')
ERROR: openstack Command 'instack-install-undercloud' returned non-zero exit status 1

Comment 19 errata-xmlrpc 2015-08-05 13:51:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549

Comment 20 rajatpatel 2015-12-30 14:03:18 UTC
Notice: /Stage[main]/Heat::Api_cfn/Service[heat-api-cfn]/ensure: ensure changed 'stopped' to 'running'
Notice: /Stage[main]/Heat::Engine/Service[heat-engine]/ensure: ensure changed 'stopped' to 'running'
Notice: /Stage[main]/Heat::Api/Service[heat-api]/ensure: ensure changed 'stopped' to 'running'
Notice: /Stage[main]/Heat::Api_cloudwatch/Service[heat-api-cloudwatch]/ensure: ensure changed 'stopped' to 'running'
Notice: Finished catalog run in 566.71 seconds
+ rc=6
+ set -e
+ echo 'puppet apply exited with exit code 6'
puppet apply exited with exit code 6
+ '[' 6 '!=' 2 -a 6 '!=' 0 ']'
+ exit 6
[2015-12-30 08:33:16,246] (os-refresh-config) [ERROR] during configure phase. [Command '['dib-run-parts', '/usr/libexec/os-refresh-config/configure.d']' returned non-zero exit status 6]

[2015-12-30 08:33:16,246] (os-refresh-config) [ERROR] Aborting...
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 562, in install
    _run_orc(instack_env)
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 494, in _run_orc
    _run_live_command(args, instack_env, 'os-refresh-config')
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 325, in _run_live_command
    raise RuntimeError('%s failed. See log for details.' % name)
RuntimeError: os-refresh-config failed. See log for details.
Command 'instack-install-undercloud' returned non-zero exit status 1
[stack@instack ~]$ sudo rpm -qa|grep -i instack
instack-0.0.8-1.el7ost.noarch
instack-undercloud-2.2.0-1.el7ost.noarch
[stack@instack ~]$

Comment 23 bigswitch 2016-01-14 15:29:51 UTC
I am trying to install RHOSP7 under cloud..I see following error even though i have unstack packages..I have copied package details below as well..This is on RHEL 7.1..
Can I get some help...



+ exit 6
[2016-01-13 22:23:56,717] (os-refresh-config) [ERROR] during configure phase. [Command '['dib-run-parts', '/usr/libexec/os-refresh-config/configure.d']' returned non-zero exit status 6]

[2016-01-13 22:23:56,718] (os-refresh-config) [ERROR] Aborting...
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 526, in install
    _run_orc(instack_env)
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 461, in _run_orc
    _run_live_command(args, instack_env, 'os-refresh-config')
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 297, in _run_live_command
    raise RuntimeError('%s failed. See log for details.', name)
RuntimeError: ('%s failed. See log for details.', 'os-refresh-config')
ERROR: openstack Command 'instack-install-undercloud' returned non-zero exit status 1
[stack@RHOSP7-UCD ~]$


Even though I have 

[root@RHOSP7-UCD ~]# sudo rpm -qa|grep -i instack
instack-0.0.7-2.el7ost.noarch
instack-undercloud-2.1.2-36.el7ost.noarch
[root@RHOSP7-UCD ~]#


Note You need to log in before you can comment on or make changes to this bug.