Bug 1222328 - mod_proxy_fcgi ignores timeout (fixed at 30s)
Summary: mod_proxy_fcgi ignores timeout (fixed at 30s)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: httpd
Version: 7.1
Hardware: All
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Web Stack Team
QA Contact: Martin Frodl
URL:
Whiteboard:
: 1284844 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-17 18:23 UTC by Rik Theys
Modified: 2019-08-15 04:36 UTC (History)
8 users (show)

Fixed In Version: httpd-2.4.6-34.el7
Doc Type: Bug Fix
Doc Text:
The mod_proxy_fcgi module had a hardcoded 30-second timeout for a request. Consequently, it was impossible to change the timeout. mod_proxy_fcgi has been fixed to honor the Timeout or ProxyTimeout directives, and users are now able to configure the timeout of mod_proxy_fcgi.
Clone Of:
Environment:
Last Closed: 2015-11-19 04:37:46 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2194 normal SHIPPED_LIVE httpd bug fix and enhancement update 2015-11-19 08:05:27 UTC

Description Rik Theys 2015-05-17 18:23:51 UTC
Description of problem:

Hi,

The mod_proxy_fcgi module does not respect the configured timeout. It seems this was hardcoded to 30s in the 2.4.6 (and before) release of Apache 2.4.

Since Apache 2.4.8 this was fixed.

Upstream bug report is https://bz.apache.org/bugzilla/show_bug.cgi?id=54973

Please backport this fix for RHEL7.

Rik


Version-Release number of selected component (if applicable):
httpd-2.4.6-31.el7

How reproducible:
Always

Steps to Reproduce:
1. Configure apache to forward php to php-fpm
2. Create sleep.php with sleep for 60s
3. Apache returns a 50x error after 30s

Actual results:
Timeout

Expected results:
Apache respects the configured Timeout or ProxyTimeout parameter

Additional info:

Comment 2 Joe Orton 2015-05-18 08:04:42 UTC
Thanks for the report.  If this issue is critical or in any way time sensitive, please raise a ticket through your regular Red Hat support channels to make certain it receives the proper attention and prioritization to assure a timely resolution.

Comment 6 Robert Scheck 2015-08-26 10:20:57 UTC
Cross-filed case 01498518 on the Red Hat customer portal.

Comment 9 errata-xmlrpc 2015-11-19 04:37:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2194.html

Comment 10 Joe Orton 2015-11-25 08:27:42 UTC
*** Bug 1284844 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.