Bug 1222367 - After publishing content view, content view list shows wrong information.
Summary: After publishing content view, content view list shows wrong information.
Keywords:
Status: CLOSED DUPLICATE of bug 1355752
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Content Views
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
low
low vote
Target Milestone: Unspecified
Assignee: Walden Raines
QA Contact: Katello QA List
URL:
Whiteboard:
: 1306118 (view as bug list)
Depends On:
Blocks: GSS_Sat6Beta_Tracker, GSS_Sat6_Tracker
TreeView+ depends on / blocked
 
Reported: 2015-05-18 02:47 UTC by jnikolak
Modified: 2016-09-11 15:42 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-11 15:42:02 UTC
Target Upstream Version:


Attachments (Terms of Use)
before (58.17 KB, image/png)
2015-05-18 02:47 UTC, jnikolak
no flags Details
before2 (42.45 KB, image/png)
2015-05-18 02:51 UTC, jnikolak
no flags Details
after (38.46 KB, image/png)
2015-05-18 02:51 UTC, jnikolak
no flags Details
content_view (28.63 KB, image/png)
2015-05-18 02:55 UTC, jnikolak
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 16268 0 None None None 2016-08-24 14:35:45 UTC

Description jnikolak 2015-05-18 02:47:33 UTC
Created attachment 1026546 [details]
before

Satellite 6.1

Steps to reproduce:

Created new content view -> added repository and then published it.

The status said that the content view is published.
However when going to history, there is no information.

Comment 1 jnikolak 2015-05-18 02:51:23 UTC
Created attachment 1026547 [details]
before2

Comment 2 jnikolak 2015-05-18 02:51:47 UTC
Created attachment 1026548 [details]
after

Comment 3 jnikolak 2015-05-18 02:55:01 UTC
Created attachment 1026549 [details]
content_view

If we go back to 
content view, it said that its not published, but when you click on the Name of the version. Rhel 6.6 it said that it is published

Comment 4 RHEL Program Management 2015-05-18 03:02:21 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 6 Brad Buckingham 2015-05-26 14:57:32 UTC
This bug really appears to be reporting 2 issues:

1. the History tab for a content view is not correctly listing the content view version history.  This aspect is currently being addressed by bug 1206583

2. after publishing a content view, if the user performs a 'Close' on the content view, the content view list does reflect the status in the 'Last Published' column.  

For this bug, I think we should address #2.  There is a workaround.  If the user refreshes the Content -> Content Views page, the 'Last Published' will get updated correctly.

Comment 7 Bryan Kearney 2016-08-04 20:12:02 UTC
Moving 6.2 bugs out to sat-backlog.

Comment 9 Brad Buckingham 2016-08-24 14:35:42 UTC
Created redmine issue http://projects.theforeman.org/issues/16268 from this bug

Comment 11 Brad Buckingham 2016-08-24 21:33:19 UTC
*** Bug 1306118 has been marked as a duplicate of this bug. ***

Comment 12 Bryan Kearney 2016-09-11 15:42:02 UTC

*** This bug has been marked as a duplicate of bug 1355752 ***


Note You need to log in before you can comment on or make changes to this bug.