Bug 122247 - after install, could not boot any partition due to inconsistant partition table
after install, could not boot any partition due to inconsistant partition table
Status: CLOSED DUPLICATE of bug 115980
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
rawhide
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-02 10:21 EDT by George Hein
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description George Hein 2004-05-02 10:21:09 EDT
Description of problem: It appears that during install the FAT32
partition table entry was modified at hda5 for no reason.  The install
was successful onto an existing reiserfs on hda9 using manual
partitioning. 

The problem was catastrophic in that I could not boot any partition.
(I am using AirBoot boot manager which sits in HDA-MBR (master boot
record) with W2K and several LINUX bootable partitions, each with a
separate GRUB).  

Using "BusinessCardLinux" I tried FDISK to repair problem to no avail,
then used PARTED where everything looked OK, so forced an update to
HDA5-FAT32 with a PARTED RESIZE using identical size.  This apparently
corrected the problem. 

The only previous time that I have had such a problem was when GRUB
install was to HD0 instead of the LINUX partition, thus wiping out 
AirBoot in MBR. Then I simply reloaded AirBoot from floppy.
 
Both AirBoot and BusinessaCardLinux (upon loading) indicated some
problem with FAT32 partition although the latter had no problem
displaying it.

This may be a mere fluke, hardware error or who knows - BUT if anyone
else sees it perhaps there is an install problem.

HARDWARE:IBM THINKPAD T20.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 George Hein 2004-05-21 10:12:13 EDT
this appears to be a dupe of 155980, 120128, 113201 etc

Problem re-occurred with FEDORA CORE 2 final (as well as test2)
 
In both cases I (finally) resolved problem with PARTED-RESIZE of a fat
partition - this caused a rewrite of partition table which fixed it.
Similar attempts with FDISK were unsuccessful.  

After first time I reformatted hd, all but first W2K partition.

First time fat was on hda5, second time (fed-core2-final) on hda9.
Comment 2 Jeremy Katz 2004-06-25 15:47:00 EDT

*** This bug has been marked as a duplicate of 115980 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:02:56 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.