Bug 1222529 - add install_optional_items config option to get rid of vim-minimal dependency
Summary: add install_optional_items config option to get rid of vim-minimal dependency
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dracut   
(Show other bugs)
Version: 7.3
Hardware: x86_64
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Lukáš Nykrýn
QA Contact: Release Test Team
URL:
Whiteboard:
Keywords:
Depends On: 1118988
Blocks: 1289485 1313485
TreeView+ depends on / blocked
 
Reported: 2015-05-18 12:54 UTC by Harald Hoyer
Modified: 2016-11-04 07:57 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1118988
Environment:
Last Closed: 2016-11-04 07:57:47 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2530 normal SHIPPED_LIVE dracut bug fix and enhancement update 2016-11-03 14:17:01 UTC

Description Harald Hoyer 2015-05-18 12:54:30 UTC
+++ This bug was initially created as a clone of Bug #1118988 +++

I have been getting:

dracut-install: ERROR: installing 'vi'
dracut-install: ERROR: installing '/etc/virc'
/usr/lib/dracut/dracut-install -D /var/tmp/initramfs.8LBEMd -a vi /etc/virc ps grep cat rm

When installing kernel-3.15.4 and when I intalled kernel-3.15.3.

The computer seems to work fine. However, I don't belieive I should be getting this.

Please help me to resolve it.

Thanks

--- Additional comment from Tadas Slotkus on 2014-07-20 07:01:51 EDT ---

Getting similar too. Few months ago I ran:
yum remove vim-minimal-7.4.179-1.fc20.x86_64

And today during update:
  Installing : kernel-3.15.6-200.fc20.x86_64                                                 1/6 
  Installing : kernel-modules-extra-3.15.6-200.fc20.x86_64                                   2/6 
  Updating   : kernel-headers-3.15.6-200.fc20.x86_64                                         3/6 
  Cleanup    : kernel-modules-extra-3.14.3-200.fc20.x86_64                                   4/6 
  Cleanup    : kernel-3.14.3-200.fc20.x86_64                                                 5/6 
  Cleanup    : kernel-headers-3.15.5-200.fc20.x86_64                                         6/6 
dracut-install: ERROR: installing '/etc/virc'
/usr/lib/dracut/dracut-install -D /var/tmp/initramfs.N8s7fW -a vi /etc/virc ps grep cat rm
  Verifying  : kernel-headers-3.15.6-200.fc20.x86_64                                         1/6 
  Verifying  : kernel-modules-extra-3.15.6-200.fc20.x86_64                                   2/6 
  Verifying  : kernel-3.15.6-200.fc20.x86_64                                                 3/6 
  Verifying  : kernel-modules-extra-3.14.3-200.fc20.x86_64                                   4/6 
  Verifying  : kernel-headers-3.15.5-200.fc20.x86_64                                         5/6 
  Verifying  : kernel-3.14.3-200.fc20.x86_64

--- Additional comment from Sandro Bonazzola on 2015-05-11 02:15:59 EDT ---

This is affecting also mock builds when the kernel package is one of the dependencies. Rising severity since this make such builds to fail.

--- Additional comment from David Caro on 2015-05-11 02:30:19 EDT ---

As a workaround on mock, you can install the vim-minimal package manually before running it

--- Additional comment from Tuomo Soini on 2015-05-13 14:09:36 EDT ---

dracut should depend on vim-minimal.

Same problem in rhel7.

--- Additional comment from Harald Hoyer on 2015-05-18 08:46:08 EDT ---

commit 54b68829b60bc3f4c28cfca1ab0336584fe1e74c


Workaround:

echo 'install_items=" ps grep cat rm "' > /etc/dracut.conf.d/50-no-vi.conf

--- Additional comment from Harald Hoyer on 2015-05-18 08:47:08 EDT ---

Comment 3 Jan Stodola 2016-09-06 10:23:24 UTC
Retested with dracut-033-458.el7, this issue is fixed.

Moving to VERIFIED.

Comment 5 errata-xmlrpc 2016-11-04 07:57:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2530.html


Note You need to log in before you can comment on or make changes to this bug.