Bug 1222573 - (CVE-2014-7810) CVE-2014-7810 Tomcat/JbossWeb: security manager bypass via EL expressions
CVE-2014-7810 Tomcat/JbossWeb: security manager bypass via EL expressions
Status: CLOSED ERRATA
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
impact=moderate,public=20150514,repor...
: Reopened, Security
Depends On: 1222576 1222577 1227586 1227587 1228262 1228263 1293289 1293290 1293291 1293292
Blocks: 1222578 1253310
  Show dependency treegraph
 
Reported: 2015-05-18 10:36 EDT by Martin Prpič
Modified: 2017-01-24 18:04 EST (History)
74 users (show)

See Also:
Fixed In Version: tomcat 8.0.17, tomcat 7.0.59, tomcat 6.0.44
Doc Type: Bug Fix
Doc Text:
It was found that the expression language resolver evaluated expressions within a privileged code section. A malicious web application could use this flaw to bypass security manager protections.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-24 18:04:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2015:1621 normal SHIPPED_LIVE Moderate: Red Hat JBoss Web Server 2.1.0 tomcat security update 2015-08-13 15:30:33 EDT
Red Hat Product Errata RHSA-2015:1622 normal SHIPPED_LIVE Moderate: Red Hat JBoss Web Server 2.1.0 tomcat security update 2015-08-13 15:29:23 EDT
Red Hat Product Errata RHSA-2016:0492 normal SHIPPED_LIVE Moderate: tomcat6 security and bug fix update 2016-03-22 21:02:03 EDT
Red Hat Product Errata RHSA-2016:2046 normal SHIPPED_LIVE Important: tomcat security update 2016-10-10 20:38:43 EDT

  None (edit)
Description Martin Prpič 2015-05-18 10:36:28 EDT
It was found that the expression language resolver evaluated expressions within a privileged code section. A malicious web application could use this flaw to bypass security manager protections.

Upstream patches:

http://svn.apache.org/viewvc?view=revision&revision=1644019
http://svn.apache.org/viewvc?view=revision&revision=1645644

External References:

http://tomcat.apache.org/security-6.html#Fixed_in_Apache_Tomcat_6.0.44
http://tomcat.apache.org/security-7.html#Fixed_in_Apache_Tomcat_7.0.59
http://tomcat.apache.org/security-8.html#Fixed_in_Apache_Tomcat_8.0.17
Comment 1 Martin Prpič 2015-05-18 10:40:16 EDT
Created tomcat tracking bugs for this issue:

Affects: fedora-all [bug 1222576]
Affects: epel-6 [bug 1222577]
Comment 6 Timothy Walsh 2015-07-09 01:05:47 EDT
Currently builds are in progress for EAP 6.3 and JBoss Web Server 2.1.

QE Testing is in progress.
Comment 10 errata-xmlrpc 2015-08-13 11:29:53 EDT
This issue has been addressed in the following products:

  JBEWS 2 for RHEL 7
  JBEWS 2 for RHEL 6
  JBEWS 2 for RHEL 5

Via RHSA-2015:1622 https://rhn.redhat.com/errata/RHSA-2015-1622.html
Comment 11 errata-xmlrpc 2015-08-13 11:31:17 EDT
This issue has been addressed in the following products:

  Red Hat JBoss Web Server 2.1.0

Via RHSA-2015:1621 https://rhn.redhat.com/errata/RHSA-2015-1621.html
Comment 15 Jason Shepherd 2015-12-21 21:43:33 EST
Reopened as we're waiting on RHEL patches for Tomcat
Comment 16 errata-xmlrpc 2016-03-22 17:03:06 EDT
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 6

Via RHSA-2016:0492 https://rhn.redhat.com/errata/RHSA-2016-0492.html
Comment 18 errata-xmlrpc 2016-10-10 16:39:08 EDT
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7

Via RHSA-2016:2046 https://rhn.redhat.com/errata/RHSA-2016-2046.html

Note You need to log in before you can comment on or make changes to this bug.