Bug 1222834 - We ship incomplete QMP documentation
Summary: We ship incomplete QMP documentation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Miroslav Rezanina
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1222833
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-19 09:25 UTC by Markus Armbruster
Modified: 2015-12-04 16:42 UTC (History)
8 users (show)

Fixed In Version: qemu-kvm-rhev-2.3.0-3.el7
Doc Type: Bug Fix
Doc Text:
Clone Of: 1222833
Environment:
Last Closed: 2015-12-04 16:42:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2546 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2015-12-04 21:11:56 UTC

Description Markus Armbruster 2015-05-19 09:25:58 UTC
+++ This bug was initially created as a clone of Bug #1222833 +++

Description of problem:
We ship qmp-commands.txt, but not docs/qmp/qmp-events.txt docs/qmp/qmp-spec.txt.
We should either ship complete QMP documentation or none.

How reproducible:
Always

Steps to Reproduce:
1. Examine /usr/share/doc/qemu-kvm/*qmp*

Actual results:
Have only qmp-commands.txt

Expected results:
Either have qmp-commands.txt qmp-events.txt qmp-spec.txt, or nothing.

Comment 2 Miroslav Rezanina 2015-06-19 11:08:59 UTC
Fix included in qemu-kvm-rhev-2.3.0-3.el7

Comment 3 Qian Guo 2015-07-01 07:41:40 UTC
Reproduced this bug with qemu-kvm-rhev-2.1.2-23.el7.x86_64

Steps:

#  ls /usr/share/doc/qemu-kvm/*qmp*
/usr/share/doc/qemu-kvm/qmp-commands.txt

Verified this bug with qemu-kvm-rhev-2.3.0-6.el7.x86_64

# ll /usr/share/doc/qemu-kvm/*qmp*
-rw-r--r-- 1 root root 90174 6月  26 18:52 /usr/share/doc/qemu-kvm/qmp-commands.txt
-rw-r--r-- 1 root root 17899 6月  26 18:51 /usr/share/doc/qemu-kvm/qmp-events.txt
-rw-r--r-- 1 root root  9665 4月  27 22:08 /usr/share/doc/qemu-kvm/qmp-spec.txt

So this bug is fixed on x86_64 platform.

Comment 7 errata-xmlrpc 2015-12-04 16:42:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2546.html


Note You need to log in before you can comment on or make changes to this bug.