Bug 122290 - VIA graphics module fails to load.
VIA graphics module fails to load.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-02 14:00 EDT by Mike Walter
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-01 02:29:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike Walter 2004-05-02 14:00:18 EDT
Description of problem: Via module will not load. System:
AMD Duron 800
Gigabyte GA-7VM400M(F)
VIA KM400 integrated chipset
256M DDR RAM
30G MAXTOR HD
I have to load the vesa generic driver to get the GUI to run, but when
I log out or try to restart the computer, the system crashes and seems
to go into suspend mode. I must do a hard reset, and edit out "rhgb
quiet" in GRUB to restart.

Version-Release number of selected component (if applicable):
X11R6.7

How reproducible: Attempt to log out of session or restart computer
from graphical mode, monitor goes black and suspend light flashes.
During boot the message "Module via not found" is displyed.

Steps to Reproduce:
1. Log out of graphical session.
2. Press restart button.
3. Edit GRUB, remove "rhgb quiet"
4. Message display during boot "Module via failed to load".
5. VIA driver option not available in display configuration.
  
Actual results:
See above.

Expected results:
VIA chipset detected during installation, and proper module loaded.

Additional info:
VIA provides the driver module for Kernel 2.4 on their website, but I
have not been able to install it on Test 3 with kernel 2.6.
Comment 1 Alan Cox 2004-05-02 17:27:07 EDT
The proper drivers (open source) are on unichrome.sf.net but Im not
sure if they are all merged into FC2test yet
Comment 2 Mike Walter 2004-05-03 19:16:08 EDT
okay, thanks Alan. I was under the impression the driver was included
in the Xorg 6.7 release (does say that on the Xorg website), and it
does show up in the driver list when I run "X -configure" ,but the
module isn't there.
BTW I missed your post on the test-list from 5/1, talking about bug
status and via problems in X. If I had seen that I wouldn't have
opened this bug report, my apologies. MJW
Comment 3 Mike A. Harris 2004-05-04 20:47:32 EDT
X.org does contain the "via" driver.  This is a 2D-only accelerated
driver, which also is part of XFree86 4.4.0, although there are
slight differences between the X.org driver and the XFree86 one
(the X.org one is newer IIRC).

Comment 4 Mike A. Harris 2004-05-04 20:51:03 EDT
Oops.. Forgot to respond to Alan's comment above...

Alan) The unichrome drivers are not merged into our X.org X11 yet.
We currently are shipping just the stock X.org drivers.  Hopefully
the unichrome.sf.net drivers will get merged into X.org CVS head
soon, and into Mesa as well, and we can just pick up the merge from
our next sync to upstream.  Alternatively, I will probably merge
the newer driver into Fedora Core 3 development once FC2 is out the
door.
Comment 5 Mike Walter 2004-05-04 21:08:54 EDT
Since updating with yum today, everything is working fine on the
updated kernel. Seems the problem was not the VIA driver, since I am
running the VIA KM400 on the vesa generic driver. Guess you can close
this one out.
Thank you for responding and thanks for all the good work. MJW
Comment 6 Mike A. Harris 2004-10-01 02:29:30 EDT
Thanks for the update..  Setting status to "CURRENTRELEASE".

Note You need to log in before you can comment on or make changes to this bug.