Bug 122296 - glibc-2.3.3_cvs-200404291129 nptl floating point exceptions
glibc-2.3.3_cvs-200404291129 nptl floating point exceptions
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-02 15:16 EDT by Nigel Kukard
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-03 08:36:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nigel Kukard 2004-05-02 15:16:59 EDT
Description of problem:
I get "Floating point exception" when I compile
glibc-2.3.3_cvs-200404291129 with gcc 3.4.0, install it and run
practically anything which uses threads. I do not use fedora, i
downloaded cvs head using cvs and built it with the options in the
fedora src rpm.

compiling with linuxthreads works perfectly fine

Version-Release number of selected component (if applicable):
n/a

How reproducible:
100%

Steps to Reproduce:
1. install gcc 3.4.0
2. compile and install glibc cvs head as per above
3. try run say sendmail
  
Actual results:
Shutting down sendmail:                                    [  OK  ]
Starting sendmail: /etc/init.d/sendmail: line 4: 22997 Floating point
exception/usr/bin/newaliases >/dev/null 2>&1
/etc/init.d/sendmail: line 7: 22998 Floating point exceptionmakemap
hash /etc/mail/$i </etc/mail/$i
/etc/init.d/sendmail: line 7: 22999 Floating point exceptionmakemap
hash /etc/mail/$i </etc/mail/$i
/etc/init.d/sendmail: line 7: 23000 Floating point exceptionmakemap
hash /etc/mail/$i </etc/mail/$i
/etc/init.d/sendmail: line 7: 23001 Floating point exceptionmakemap
hash /etc/mail/$i </etc/mail/$i
                                                           [FAILED]

if you run anything using thread support, it returns "Floating Point
Exception"

Expected results:
it working? heh

Additional info:
Comment 1 Jakub Jelinek 2004-05-03 08:36:23 EDT
Well, if you roll your own, you are on your own debugging what's wrong
as well, the report doesn't belong here, but on sources.redhat.com/bugzilla
and need to include more relevant details, such as gdb session where
it crashed with SIGFPE etc.
It certainly works for me.

Note You need to log in before you can comment on or make changes to this bug.