Bug 122298 - nautilus-media src.rpm will not build on X86_64
nautilus-media src.rpm will not build on X86_64
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: nautilus-media (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-02 15:41 EDT by Chuck Mead
Modified: 2013-03-05 22:40 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-29 17:03:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
this is the capture from the bug-buddy applet (9.81 KB, text/plain)
2004-05-02 15:42 EDT, Chuck Mead
no flags Details

  None (edit)
Description Chuck Mead 2004-05-02 15:41:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.6)
Gecko/20040312

Description of problem:
Nautilus fails to start when entering the Gnome environment and cannot
be started after the fact.

Version-Release number of selected component (if applicable):
nautilus-2.6.0-4

How reproducible:
Always

Steps to Reproduce:
1. in runlevel 5 simply login. in runlevel 3 startx
2. nautilus crashes as soon as you enter gnome
3.
    

Actual Results:  Gnome starts but there are no desktop icons and the
file manager is unavailable. Nautilus crashes when I try to restart it
as well.

Expected Results:  Obviously I should have been able to enter Gnome
and have a complete environment.

Additional info:

I tried to rebuild all of the Nautilus src.rpms and the nautilus-media
src.rpm fails to build.
Comment 1 Chuck Mead 2004-05-02 15:42:11 EDT
Created attachment 99889 [details]
this is the capture from the bug-buddy applet
Comment 2 Chuck Mead 2004-05-02 15:45:38 EDT
I also tried to rebuild the 3 Nautilus src.rpms.

nautilus-2.6.0-4.src.rpm
nautilus-cd-burner-2.6.0-1.src.rpm
nautilus-media-0.8.0-1.src.rpm 

The first two build successfully but the 3rd will not build. Here is
the spew from the failed build:

gcc -O2 -g -pipe -o nautilus-audio-view audio-play.o audio-view.o
nautilus-audio-view.o main.o -Wl,--export-dynamic -Wl,--export-dynamic
-L/usr/X11R6/lib64 -lnautilus -leel-2 -lgnomeui-2 -lSM -lICE
-lgailutil -lglade-2.0 -lbonoboui-2 -lgnomecanvas-2 -lgnome-2
/usr/lib/libpopt.so -lart_lgpl_2 -lpangoft2-1.0 -lgtk-x11-2.0
-lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lpangoxft-1.0 -lpangox-1.0
-lpango-1.0 -lbonobo-2 -lgnomevfs-2 -lbonobo-activation
../media-info/.libs/libgstmedia-info.a -pthread -lgstgconf-0.8
-lgconf-2 -lORBit-2 -lgstreamer-0.8 -lgobject-2.0 -lgmodule-2.0 -ldl
-lgthread-2.0 -lxml2 -lpthread -lz -lm -lglib-2.0
/usr/lib/libpopt.so: could not read symbols: Invalid operation
collect2: ld returned 1 exit status
make[2]: *** [nautilus-audio-view] Error 1
make[2]: Leaving directory
`/home/csm/redhat/BUILD/nautilus-media-0.8.0/audio-view'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/csm/redhat/BUILD/nautilus-media-0.8.0'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.47643 (%build) 

So to be certain there was nothing wrong with rpm I rebuilt and
installed all of it's rpms and repeated the process which generated
the exact same error. Does anyone have any recommendations for getting
nautilus-media to build? It seems odd to me that it built for the
release but not for me here on a live machine. FYI all RPM's are
completely stock with a fresh build (not an upgrade installation).
Comment 3 Chuck Mead 2004-05-06 14:09:36 EDT
I sent this to the upstream author and his only comment was why would
we be trying to build against /usr/lib instead of /usr/lib64.

Beyond that I have been unable to account for why nautilus craps out
on this x86_64 as soon as I start gnome. There were a few others who
have reported this on the testers list. I dunno if they have fixed it
for themselves. My attempts to fix it led me to this inability to
rpmbuild --rebuild nautilus-media. How was it built in the build system?
Comment 4 Justin M. Forbes 2004-05-06 14:45:03 EDT
The build issues can most likely be fixed with a spec file change. 
The build system can build it because beehive should not have the
32bit popt installed when building 64bit packages so the first place
config finds the file is /usr/lib64.  As for the non functional gnome,
I cannot reproduce on any of my test3/rawhide installs on x86_64. Any
word on where it is actually hanging?  
Comment 5 Karen Spearel 2004-05-06 16:37:01 EDT
Ok, I have seen this once (the original report...no desktop background
and no icons, logged into runlevel 5 directly) but on an Athlon i386
system...not an Athlon 64.  I assumed it was something I had broken
since the previous reboot...I had been experimenting with vncserver
and had uncommented 2 lines in the default ~/.vnc/xstartup.  This was
on a system that hasn't seen a fresh FC2 T3 install but had been
ud2dated on a fairly regular basis from rawhide.

The panels were running but there was nothing on the desktop...and
nautilus wouldn't start manually.  I rebooted and the same
thing...looked around but didn't see anything that looked wrong.  Out
of ideas, I disabled the vncserver service, ran up2date (Monday
morning) and rebooted...and my desktop was back...has been fine since.  

As I said, this seemingly was provoked by me experimenting with vnc
between one 1386 system and another i386...the x86_64 system was on
the network but wasn't being used at the time...so this probably has
nothing to do with anything...I cannot duplicate the problem
now...have tried to running vncserver on my X86_64 system to do so but
I can't provoke it now.  When reported by the OP, there was definite
forest-trees disconnect here.
Comment 6 Chuck Mead 2004-05-06 21:34:41 EDT
I have run an strace on it from the command line and this is what I see:

clone(child_stack=0x409ff8b0,
flags=CLONE_VM|CLONE_FS|CLONE_FILES|CLONE_SIGHAND|CLONE_THREAD|CLONE_SYSVSEM|CLONE_SETTLS|CLONE_PARENT_SETTID|CLONE_CHILD_CLEARTID|CLONE_DETACHED,
parent_tidptr=0x409ff9f0, tls=0x409ff960, child_tidptr=0x409ff9f0) = 4863
futex(0x3cc7283c28, FUTEX_WAKE, 1)      = 1
writev(18, [{"GIOP\1\2\1\0\16\3\0\0", 12},
{"h\352\377\277\3\0\0\0\0\0\0\0\34\0\0\0\0\0\0\0\225P\330"..., 782}],
2) = 794
futex(0x5e19e0, FUTEX_WAIT, 0, NULL)    = 0
futex(0x5e19d0, FUTEX_WAIT, 2, NULL)    = -1 EAGAIN (Resource
temporarily unavailable)
futex(0x5e19d0, FUTEX_WAKE, 1)          = 0
futex(0x5e19a0, FUTEX_WAKE, 1)          = 0
socket(PF_UNIX, SOCK_STREAM, 0)         = 23
fcntl(23, F_SETFL, O_RDONLY|O_NONBLOCK) = 0
fcntl(23, F_SETFD, FD_CLOEXEC)          = 0
connect(23, {sa_family=AF_UNIX,
path="/tmp/orbit-csm/linc-1301-0-44c3c34a648ed"}, 43) = 0
write(20, "A", 1)                       = 1
writev(23, [{"GIOP\1\2\1\0\224\1\0\0", 12},
{"8\354\377\277\3\0\0\0\0\0\0\0\34\0\0\0\0\0\0\0\274\2|\200"...,
404}], 2) = 416
futex(0x5e19e0, FUTEX_WAIT, 1, NULL)    = 0
futex(0x5e19d0, FUTEX_WAIT, 2, NULL)    = 0
futex(0x5e19d0, FUTEX_WAKE, 1)          = 0
futex(0x5e19a0, FUTEX_WAIT, 2, NULL)    = 0
futex(0x5e19a0, FUTEX_WAKE, 1)          = 0
writev(23, [{"GIOP\1\2\1\0\234\1\0\0", 12},
{"\230\354\377\277\3\0\0\0\0\0\0\0\34\0\0\0\0\0\0\0\274\2"..., 412}],
2) = 424
futex(0x5e19e0, FUTEX_WAIT, 2, NULL)    = 0
futex(0x5e19a0, FUTEX_WAKE, 1)          = 0
writev(23, [{"GIOP\1\2\1\0\214\1\0\0", 12},
{"\370\353\377\277\3\0\0\0\0\0\0\0\34\0\0\0\0\0\0\0\274\2"..., 396}],
2) = 408
futex(0x5e19e0, FUTEX_WAIT, 3, NULL)    = 0
futex(0x5e19a0, FUTEX_WAKE, 1)          = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
write(3, "\22\0\20\0\1\0\0\2\4\1\0\0\37\0\0\0\10_ID%\0\0\00011c0"...,
72) = 72
write(3, " \0\2\0\0\0\0\0", 8)          = 8
write(3, "+\0\1\0", 4)                  = 4
read(3, 0x7fbfffe5e0, 32)               = -1 EAGAIN (Resource
temporarily unavailable)
select(4, [3], NULL, NULL, NULL)        = 1 (in [3])
read(3, "\34\0G\0\1\0\0\2\4\1\0\0\207\5\1\0\0\0\0\0\0\0\0\0n\222"...,
32) = 32
read(3, "\1\2J\0\0\0\0\0\25\0\0\1\0\0\0\0\0\0\0\0\0\0\0\0Hg\0\0"...,
32) = 32
clone(child_stack=0,
flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD,
child_tidptr=0x2a9650f1f0) = 4899
wait4(4899, [WIFEXITED(s) && WEXITSTATUS(s) == 0], 0, NULL) = 4899
--- SIGCHLD (Child exited) @ 0 (0) ---
rt_sigreturn(0x5e76e0)                  = 4899
exit_group(1)

Hopefully that helps.
Comment 7 Chuck Mead 2004-05-07 09:43:49 EDT
bug 122662 is the one which started all this. I found the
nautilus-media problem while trying to figure out why nautilus was
crashing.
Comment 8 Colin Walters 2004-09-17 14:28:33 EDT
nautilus-media seems to build fine on x86_64 in beehive.  Can you
still reproduce the problem?
Comment 9 John Thacker 2006-10-29 17:03:19 EST
Closing per lack of response to previous request for information.  Note that FC3
and FC4 are supported by Fedora Legacy for security fixes only.  Please install
a still supported version and retest.  If it still occurs on FC5 or FC6,
please reopen and assign to the correct version.  Otherwise, if this a security
issue, please change the product to Fedora Legacy.  Thanks, and we are sorry
that we did not get to this bug earlier.

Note You need to log in before you can comment on or make changes to this bug.