Bug 1223068 - Regression introduced by the simple paged results fixes.
Summary: Regression introduced by the simple paged results fixes.
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base   
(Show other bugs)
Version: 6.7
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Noriko Hosoi
QA Contact: Viktor Ashirov
URL:
Whiteboard:
Keywords: Regression, TestBlocker
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-19 17:50 UTC by Sankar Ramalingam
Modified: 2015-07-22 06:37 UTC (History)
6 users (show)

Fixed In Version: 389-ds-base-1.2.11.15-58.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-22 06:37:42 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1326 normal SHIPPED_LIVE 389-ds-base bug fix and enhancement update 2015-07-20 17:53:07 UTC

Description Sankar Ramalingam 2015-05-19 17:50:28 UTC
Description of problem: Automated acceptance tests hangs at running filter tests. Further troubleshooting revealed that it hangs when deleting a sub suffix for vfilter cleanup tests.

Version-Release number of selected component (if applicable): 389-ds-base-1.2.11.15-56

How reproducible: Consistently with 1.2.11.15-56 version.

Steps to Reproduce:
1. Run automated acceptance tests for filter test suite.
2. Check if filter cleanup tests completes without any hang.
3. The actual failure is at deleting a Sub suffix in vfilter cleanup tests.

Actual results: Deleting a subsuffix fails.

Expected results: Deleting a subsuffix should succeed.

Additional info: Deleting a suffix succeeds. Moreover, this issue is not reproducible with previous versions of 389-ds-base-1.2.11.

Comment 8 Sankar Ramalingam 2015-05-27 11:36:08 UTC
Filter acceptance tests passed 100%. Hence, marking the bug as Verified.

############## Result  for  backend test :   filter run
    filter run elapse time : 00:03:26
    filter run Tests PASS      : 100% (147/147)

############## Result  for  backend test :   filter cleanup
    filter cleanup elapse time : 00:00:22
    filter cleanup Tests PASS      : 100% (1/1)

Build tested:
389-ds-base-1.2.11.15-57

Comment 9 Noriko Hosoi 2015-05-31 00:04:06 UTC
Let me reopen this bug for the failure of the CI test ticket47824_test.py.

Comment 10 Sankar Ramalingam 2015-06-21 09:15:23 UTC
Filter acceptance and simple paged results passed 100% with tet automation.
Build tested:
 [root@dhcp35-49 ~]# rpm -qa |grep -i 389-ds-base
389-ds-base-libs-1.2.11.15-60.el6.x86_64
389-ds-base-1.2.11.15-60.el6.x86_64
SIMPLEPAGED run
	 100% (17/17)

filter run
	 100% (147/147)
filter cleanup
	 100% (1/1)


However, I am facing some issues with running ticket47824_test.py. It looks like the script need to be fixed.

Could not open LDIF file "/export/test/ds/dirsrvtests/tmp/ticket47824_2.ldif", errno 13 (Permission denied)
Aborting all Import threads...
Import threads aborted.
Closing files...
Import failed.
nsTaskTotalItems: 2


ERROR:lib389:Error: import task import_06212015_142927 for file /export/test/ds/dirsrvtests/tmp/ticket47824_2.ldif exited with -23

Comment 11 Sankar Ramalingam 2015-06-21 09:18:33 UTC
with selinux permissive mode, the script ran fine except one issue with arguments for simplepaged search.

INFO:lib389:Import task import_06212015_144105 for file /export/test/ds/dirsrvtests/tmp/ticket47824_2.ldif completed successfully
INFO:lib389:

######################### SEARCH ALL ######################

INFO:lib389:Bind as cn=Directory Manager and add the READ/SEARCH SELFDN aci
INFO:lib389:Returned 64 entries.

INFO:lib389:64 entries are successfully imported.
INFO:lib389:

############ SEARCH WITH SIMPLE PAGED RESULTS CONTROL #############



The failure reported is this one...

     page_size = 4
>       req_ctrl = SimplePagedResultsControl(True, size=page_size, cookie='')
E       TypeError: __init__() got an unexpected keyword argument 'cookie'

Comment 12 Viktor Ashirov 2015-06-22 23:01:14 UTC
> The failure reported is this one...
> 
>      page_size = 4
> >       req_ctrl = SimplePagedResultsControl(True, size=page_size, cookie='')
> E       TypeError: __init__() got an unexpected keyword argument 'cookie'

This is because of the older version of python-ldap that is shipped with RHEL6. After updating python-ldap to 2.4.19 I was able to run this test case:

============================= test session starts ==============================
platform linux2 -- Python 2.6.6 -- py-1.4.28 -- pytest-2.7.1 -- /usr/bin/python
rootdir: /export/test/ds/dirsrvtests/tickets, inifile: 
collected 2 items 

ds/dirsrvtests/tickets/ticket47824_test.py::test_ticket47824_run PASSED
ds/dirsrvtests/tickets/ticket47824_test.py::test_ticket47824_final PASSED

========================== 2 passed in 156.46 seconds ==========================

Marking as VERIFIED.

Comment 13 errata-xmlrpc 2015-07-22 06:37:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1326.html


Note You need to log in before you can comment on or make changes to this bug.