This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 122307 - up2date complains about gpg signature after grabbing any package
up2date complains about gpg signature after grabbing any package
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-02 19:58 EDT by Alex Markley
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-07 13:59:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alex Markley 2004-05-02 19:58:14 EDT
Description of problem: Up2date complains about not recognizing the
GPG signature of any updated fedora package it downloads.

Version-Release number of selected component (if applicable): Red Hat
Update Agent 4.3.17

How reproducible: Always

Steps to Reproduce:
1.Start up2date
2.Begin package update
3.Up2date complains about GPG signature.
  
Actual results: Updates can not be fully automated, since it is
nessicary to confirm each and every package.

Expected results: Updates should run smoothly out of the box.

Additional info: None
Comment 1 Bill Roman 2004-05-06 18:02:42 EDT
This appears to be a duplicate of bug 119957.

rpm --import /usr/share/doc/fedora-release*/RPM-GPG-KEY*
Comment 2 Adrian Likins 2004-05-07 13:59:25 EDT
The fedora key needs to be imported, fedora versions
should be doing this automatically in gui mode
(or warning in commandline mode). 

However, for versions that are in rawhide, they
import the rawhide key, not the fedora key by default.

Official fedora versions should import the proper
key by default, avoiding this problem.

Note You need to log in before you can comment on or make changes to this bug.