Bug 1223117 - gnome-online-accounts can not add google account
Summary: gnome-online-accounts can not add google account
Keywords:
Status: CLOSED DUPLICATE of bug 1340203
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-online-accounts
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Debarshi Ray
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-19 22:18 UTC by Julio Ordonez Viales
Modified: 2019-11-06 15:16 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 14:41:23 UTC


Attachments (Terms of Use)
screenshot (106.89 KB, image/png)
2015-05-19 22:18 UTC, Julio Ordonez Viales
no flags Details

Description Julio Ordonez Viales 2015-05-19 22:18:30 UTC
Created attachment 1027418 [details]
screenshot

Description of problem:

I try to add google account to gnome online account, it presents google login screens, after I log in it says that my credentials have expired.

Version-Release number of selected component (if applicable):
gnome-online-accounts-3.16.2-1.fc22.x86_64 

How reproducible:
open gnome-online-accounts and try to add a google account. I already had google account added before the last update but then I couldn't open my email (evolution) "no credentials found on the keyring" , deleted the account from the gnome-online-accounts and tried to add it back same issue

Steps to Reproduce:
1.open online accounts
2.  > add account > google
3. > log in and provide permissions

Actual results:
error
credentials have expired sign in to enable this account
Expected results:

should be able to add the google account
Additional info:

Comment 1 Jens Lautenbacher 2015-05-26 23:56:25 UTC
This also applies for my exchange account.

And my IMAP account.

So basically it is completely broken after update to Fedora 22

Comment 2 Debarshi Ray 2015-05-27 10:59:47 UTC
It could be that gnome-keyring is broken. What happens if you use seahorse to look at your keyring?

Comment 3 Andreas Spengler 2015-09-01 08:15:12 UTC
Same issue here for me, both with version 3.16.2 and 3.16.3. 

I tried running seahorse - it shows a list of keyrings, certificates etc.

The gnome-keyring is locked and can be unlocked with my account's password. Then it is unlocked. Nothing appears in the main window, when selecting the gnome-keyring.

Comment 4 Andreas Spengler 2015-09-01 08:24:13 UTC
Interestingly enough, downgrading to 3.16.2 at least allowed me to add my facebook account again.

So the problem seems to be with the Google account only.

Comment 5 Geezus 2015-09-10 20:41:30 UTC
Like the person above, my Facebook account works but neither of my Google accounts will.

Comment 6 Geir 2016-01-08 07:57:29 UTC
I confirm that this is an issue with Fedora 23 also. Deleting and re-creating the Google account in 'gnome-control-center online-accounts' does not help. I can log in to my Google account, give Gnome access, but back in the GUI it still reports "Credentials have expired - Sign-in to enable this account". It seems that Evolution 3.18 is still able to (natively) access gmail and calendars, but it fails on my contact list.

Comment 7 core bots 2016-01-22 09:16:24 UTC
I too can confirm that my system is unable to log in to google via the online-accounts. same issue as above. I've installed all updates but issue remains. is there a fix coming in the near future or we say bye bye to google ?

Comment 8 Karl Latiss 2016-07-18 10:04:32 UTC
This is still an issue. It was working as expected in Fedora 23 however stopped working after an upgrade to Fedora 24. Removing and re-adding the account does not work either.

Comment 9 Fedora End Of Life 2016-07-19 14:10:22 UTC
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Comment 10 Tom Prince 2016-08-09 18:38:11 UTC
I've run into this on fedora 24 as well.

Comment 11 Damian 2016-08-13 09:10:23 UTC
Same thing here, it did work on Gnome 3.18 (Ubuntu 16.04), but not under 3.20 (Fedora 24).

Comment 12 Karl Latiss 2016-08-23 10:08:47 UTC
I find if I run

/usr/libexec/goa-daemon --replace

I get my connection back (until I log out).

Comment 13 Debarshi Ray 2016-08-23 14:41:23 UTC
(In reply to Tom Prince from comment #10)
> I've run into this on fedora 24 as well.

This and ...

(In reply to Damian from comment #11)
> Same thing here, it did work on Gnome 3.18 (Ubuntu 16.04), but not under
> 3.20 (Fedora 24).

... this makes me think that it is a duplicate of bug 1340203.

*** This bug has been marked as a duplicate of bug 1340203 ***

Comment 14 Fernando 2016-12-14 15:48:34 UTC
Still happening in a fresh installation of Fedora 25. I can't add either Google or Facebook accounts.

Comment 15 Conor Byrne 2016-12-14 20:32:46 UTC
I am also having this problem on Fedora 25.

I click validate credentials, sign into google and grant gnome permissions, the window closes and nothing changes. It still says "Credentials have expired. Sign in to activate this account."

Comment 16 Bavarian 2016-12-26 11:41:33 UTC
Same issue here - Fedora 25 Google account.

Comment 17 FroL_Onn 2017-06-10 12:14:47 UTC
(In reply to Karl Latiss from comment #12)
> I find if I run
> 
> /usr/libexec/goa-daemon --replace
> 
> I get my connection back (until I log out).

This helped me! Thank you!

Also influenced on Fedora 25.

Comment 18 Paul M. Summitt 2019-11-06 15:16:37 UTC
Similar issue in Fedora 31.  Also can't sign in to gmail using Thunderbird.  Facebook and MSN accounts work fine.  Chromium signs in to google account also.


Note You need to log in before you can comment on or make changes to this bug.