Bug 1223173 - python-ipaddress-1.0.7 breaks pypolicyd-spf, which uses python-ipaddr
Summary: python-ipaddress-1.0.7 breaks pypolicyd-spf, which uses python-ipaddr
Status: CLOSED DUPLICATE of bug 1230373
Alias: None
Product: Fedora
Classification: Fedora
Component: python-ipaddress
Version: 22
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Nathaniel McCallum
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-20 02:23 UTC by Bojan Smojver
Modified: 2015-06-28 21:34 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2015-06-28 21:34:30 UTC


Attachments (Terms of Use)

Description Bojan Smojver 2015-05-20 02:23:53 UTC
Description of problem:
It seems that python-ipaddress provides the same thing as python-ipaddr, but then causes pypolicyd-spf to fail with stuff like this:

May 19 13:26:42 <host> policyd-spf[9646]: AddressValueError: '<IPv4_address>' does not appear to be an IPv4 or IPv6 address. Did you pass in a bytes (str in Python 2) instead of a unicode object? 

Version-Release number of selected component (if applicable):
python-ipaddress-1.0.7-1.fc22

How reproducible:
Always.

Steps to Reproduce:
1. Run pypolicyd-spf.
2. Fails when calling functions that deal with IP addresses.

Actual results:
Fails to run properly.

Expected results:
Was OK before this was pushed into F22.

Additional info:
python-ipaddr appears to be covering the same ground.

Comment 1 Anthony Messina 2015-06-27 19:50:36 UTC
I can confirm this same issue.

Comment 2 Anthony Messina 2015-06-28 13:29:13 UTC
I can also confirm that pypolicyd-spf-1.3.1-3.fc22 from http://koji.fedoraproject.org/koji/buildinfo?buildID=656884 does not fix the issue unfortunately.

Comment 3 Bojan Smojver 2015-06-28 21:32:49 UTC
(In reply to Anthony Messina from comment #2)
> I can also confirm that pypolicyd-spf-1.3.1-3.fc22 from
> http://koji.fedoraproject.org/koji/buildinfo?buildID=656884 does not fix the
> issue unfortunately.

Of course it doesn't. That is due to bug #1232595.

Comment 4 Bojan Smojver 2015-06-28 21:34:30 UTC

*** This bug has been marked as a duplicate of bug 1230373 ***


Note You need to log in before you can comment on or make changes to this bug.