Bug 12232 - Boot installer fails with signal 4
Boot installer fails with signal 4
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Brock Organ
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-13 20:42 EDT by John Saxer
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-19 15:20:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Saxer 2000-06-13 20:42:05 EDT
After booting from floppy, and starting to load from CD, after answering
questions about keyboard, etc., the boot aborts with the message:

install exited abnormally -- received signal 4

It then kills active processes, unmount the filesystems /tmp/rhimage and
/proc, and halts

System is a Cyrix 6686GX 233 in a PC104 enclosure, with IDE HDD and CDROM
Comment 1 Michael Fulbright 2000-06-14 10:32:22 EDT
Do any of our later releases work better?
Comment 2 John Saxer 2000-06-19 15:20:32 EDT
OK, I have solved it. I suggest that this get added in some way to a FAQ, or
other support database, if possible.

Here is what was happening: The CPU/System I was installing on is a small,
embedded type system, with a small power supply. When the CDROM reader starts to
spin up, there is a drain on the power, and this causes errors in the CPU, which
was interpreted as type  or type 7 faults in the program running at the time.
Powering the CDROM reader seperately from the CPU solved this problem.

Hard to diagnose, since the CPU did not fail completely. I onl;y stumbled across
the answer when I hooked up a second system, and rather than re-wire the reader,
left the power connected to the first system, and just moved the data cables. It
worked!
Comment 3 IBM Bug Proxy 2004-04-30 15:01:58 EDT
----- Additional Comments From gjlynx@us.ibm.com(prefers email via gjohnson@austin.ibm.com)  2004-04-30 15:02 -------
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=122132 
Comment 4 IBM Bug Proxy 2004-04-30 15:03:10 EDT
----- Additional Comments From gjlynx@us.ibm.com(prefers email via gjohnson@austin.ibm.com)  2004-04-30 15:05 -------
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=122132 

Note You need to log in before you can comment on or make changes to this bug.