Bug 122335 - drive mount applet can't unmount a usb disk
drive mount applet can't unmount a usb disk
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-03 09:06 EDT by Brian G. Anderson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-05 10:32:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian G. Anderson 2004-05-03 09:06:33 EDT
Description of problem:
I've set up a usb disk in /etc/fstab which is user controllable and I
can mount and unmount from the command line.  I added the drive mount
applet to my desktop and changed it to use /mnt/usbdisk where I mount
my usb disk.

When I click on the drivemount icon, the usb disk is mounted and a
disk icon appears on my desktop.  However, whenever I click it again
it can't unmount it and claims that the device is busy.  However, I
can unmount it using the desktop icon by right clicking and selecting
the "unmount volume" option.

On a related note:  the applet has options for icons distinguishing
between when the disk is mounted or not, but these are not active when
I set it up for a usb disk.  Shouldn't they be?  Also isn't a desktop
disk icon redundant now that I have to use the disk mount applet to
mount the disk?


Version-Release number of selected component (if applicable):
gnome-applets-2.6.0-4

How reproducible:
always


Steps to Reproduce:
1. setup usb disk and drive mount icon
2. click on disk applet to mount
3. try and unmount by clicking on disk applet again
  
Actual results:
Mount failed because device busy

Expected results:
umount disk


Additional info:
Comment 1 Mark McLoughlin 2004-07-21 13:03:24 EDT
Does umount /mnt/usbdisk work from the command line?
Comment 2 Brian G. Anderson 2004-07-21 14:53:17 EDT
No /mnt/usbdisk doesn't work either.  The only way to unmount is to
right-click on the usbdisk icon gnome puts up and select "Unmount volumne"
Comment 3 Mark McLoughlin 2004-07-21 15:19:35 EDT
Ah, I see. This must be just a conflict between the drivemount applet
and Nautilus. Nautilus probably adds a FAM monitor on the directory
which is why its being reported as busy. The drivemount applet should
probably ask Nautilus to unmount the volume or something.
Comment 4 Brian G. Anderson 2004-07-21 15:25:48 EDT
Right.  Would that also correct the problem where one cannot unmount
from the command line?
Comment 5 Mark McLoughlin 2005-01-05 10:32:21 EST
The applet has been completely re-worked upstream in GNOME 2.10 to use
gnome-vfs just like nautilus, so I'll close this bug as resolved
UPSTREAM. If you see the issue in later versions of GNOME (I don't
expect you will), then please do re-open the bug.

Note You need to log in before you can comment on or make changes to this bug.