Bug 12235 - is debian a valid upgrade partition?
Summary: is debian a valid upgrade partition?
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-14 02:09 UTC by Rod m. Stewart
Modified: 2007-04-18 16:27 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-14 14:28:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rod m. Stewart 2000-06-14 02:09:46 UTC
After doing a workstation install on a trashable partition I wanted to try
an upgrade (in text mode).  My drive is partitioned as follows
	/dev/hda1	/
	/dev/hda2	(rh-beta / )
	/dev/hda5	/usr
	/dev/hda6	(debian-potato /)
	/dev/hda7	/home

The Beta install only knows about /dev/hda2 so as not to trash any
partitions.

During the upgrade when it went to find the posible partitions on which it
would upgrade it selected:
	/dev/hda1
	/dev/hda2
	/dev/hda6
The first two are correct.  It is the last one I'm a bit confused about. 
Will it really try to upgrade my Debian partition?  (I didn't try it, as
I've not mastered setting up a new Debian install by solely using chroot.)

Comment 1 Michael Fulbright 2000-06-14 14:28:05 UTC
The installer looks for partitions which contain a /etc/fstab file. There is
no real way to distinguish all the variants of Linux - all we can do is
attempt to find something that looks like a root partition.



Comment 2 Dale Lovelace 2000-06-16 19:40:39 UTC
  Could it possibly look for both a /etc/fstab and a /etc/redhat-release?


Note You need to log in before you can comment on or make changes to this bug.