Bug 122353 - control characters misinterpretted in vnc and Xnest
control characters misinterpretted in vnc and Xnest
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
http://freedesktop.org/bugzilla/show_...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-03 12:37 EDT by Marc Milgram
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-12 11:24:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc Milgram 2004-05-03 12:37:18 EDT
Description of problem:
vncserver and Xnest don't handle control keys

Version-Release number of selected component (if applicable):
xorg-x11-6.7.0-0.5

How reproducible:
easily

Steps to Reproduce:
1.Start vncserver
2.Start vncclient
3.Start xterm in vncclient
4.attempt to use control characters in xterm.
  
Actual results:
control characters interpretted as regular (non-control) characters.

Expected results:
Control characters act as expected.

Additional info:
Can reproduce using Xnest instead of vnc.
Comment 1 Marc Milgram 2004-05-04 10:50:22 EDT
I found some odd behaviour.  I have this problem if I run vncviewer
normally from my workstation.

Last night I ssh'ed from my home machine which runs fedora core 1 to
my work machine which is running fedora core bleeding edge.  From the
bleeding edge machine, I ran vncviewer.  I was shocked that control
characters worked as expected!

But, this doesn't work if ssh from the bleeding edge desktop, and pop
up a VNC viewer.  Nor does it work if I just pop up a vncviewer from
the bleeding edge desktop.

As I mentionned before, this also affects Xnest (is why I clasified it
as an X11 bug).
Comment 2 Mike A. Harris 2004-10-12 03:04:12 EDT
Since this bugzilla report was filed, there have been several major
updates to the X Window System, which may resolve this issue.  Users
who have experienced this problem are encouraged to upgrade to the
latest version of Fedora Core, which can be obtained from:

        http://fedora.redhat.com/download

If this issue turns out to still be reproduceable in the latest
version of Fedora Core, please file a bug report in the X.Org
bugzilla located at http://bugs.freedesktop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.
Comment 3 Marc Milgram 2004-10-12 08:26:44 EDT
I added bug 1609 to freedesktop.org
Comment 4 Mike A. Harris 2004-10-12 11:24:48 EDT
Thanks for the X.Org bug number.  We'll track this in the X.Org
bug tracker now, and review any fixes which become available
for consideration in future updates.

Setting status to "UPSTREAM" for tracking.

Note You need to log in before you can comment on or make changes to this bug.