This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 122357 - rsync copies the wrong files
rsync copies the wrong files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rsync (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jay Fenlason
Mike McLean
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-05-03 13:31 EDT by Nick Lawes
Modified: 2014-08-31 19:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-04 17:44:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Lawes 2004-05-03 13:31:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
I use a backup script to create rotating backups using rsync. The
command that is run is like:

rsync -axR -e ssh --delete /home/ backup-server:/backup/machine/daily.0

and works fine from all other machines, and this machine using test2.

The daily.0 directory already exists, and contains the files from the
previous day. Backup rotation is done by copying this directory to
daily.1 using cp -al. So when the backup runs, the only files copied
across should be those that have changed since the last backup, and
this will typically take less than an hour to complete. Using 2.6.1 I
found the backup was running for hours, and seemed to be copying
everything.

I then tried looking for files with 1 link to them, as that should
represent a changed file... One of these was /etc/fedora-release. The
file in the backup directory contained the contents of
/etc/cups/printer.conf !! Clearly a problem.

Version-Release number of selected component (if applicable):
rsync-2.6.1-0.pre1

How reproducible:
Always

Steps to Reproduce:
1.running my backup script will do this. Presumably any similar copy
will fail...
    

Actual Results:  Target file contents differ from source

Expected Results:  Target file contents same as the source

Additional info:

I've compiled the 2.6.2 version of the source, and this fixes the
problem. There was a known problem with 2.6.1 supposedly only relating
to files in the root of the copied tree. It seems more widespread to me.

I've entered this bug to try to ensure that the latest rsync makes it
into the final release, since this is a very severe problem... I've
hosed all of my backups for the test3 machine (obviously acceptable
for testing, but not for release!)
Comment 1 Warren Togami 2004-05-03 22:04:36 EDT
rsync-2.6.2-0 should be in rawhide tomorrow, otherwise I have copied
it to fedora.us RPMS.updates for 1.92.  Please test and report back.
Comment 2 Nick Lawes 2004-05-04 17:11:56 EDT
I've downloaded the update from fedora.us, installed it, removed my
compiled version. Running my backup script is now successful. I've
made a few small copies to double-check, and they are okay too.

I would consider this bug fixed. Many thanks.

Note You need to log in before you can comment on or make changes to this bug.